We help IT Professionals succeed at work.

Free busy information not working

s a
s a used Ask the Experts™
on
Hey all, we just did a migration from Exchange 2003 to Exchange 2007 and everyone's free busy information is not showing up...I tried doing the free/busy switches which did not fix  the issue

Things we did recently:
migrated to exchange 2007 about a month ago (I think it was working then)
decomm'd old exchange server yesterday

Thanks


Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Did you try copying the Free Busy System folder  from exchange 2003  to Exchange 2007.

1. Open Exchange 2003 System Manager.
2. Scroll to Administrative Groups and Folders
3. Right click Public Folders - View System Folders
4. Expand Schedule + Free Busy
5. You should see Free Busy subfolders starting with EX: Right click each  one properties, replication tab. Add your Exchange 2007 server.

Let it replicate and check after few hours or minutes depnding on your environement .
s ait

Author

Commented:
We decom'd the old exchange server and removed it from the domain...again, I think this is a fairly recent issue and was working fine after the migration until a few days ago...so not sure if it has anything to do with the timeline
did you replicae the folder before decom ? do you have any errors showing in event viewer ?
s ait

Author

Commented:
I see the below errors on the new exchange 2007 server:
Definitely since the decomm yesterday
event Id: 9385, Source: mxexchange sa
Microsoft Exchange System Attendant failed to read the membership of the universal security group '/dc=net/dc=atlanticinvestment/ou=Microsoft Exchange Security Groups/cn=Exchange Servers'; the error code was '8007203a'. The problem might be that the Microsoft Exchange System Attendant does not have permission to read the membership of the group.
 eventid: 9144, Source: mxexchange sa
NSPI Proxy failed to connect to Global Catalog s2k3aimdc1.atlanticinvestment.net over transport Tcp/Ip. This server is down or unreachable. Clients will not be directed to this GC until it is available again.
 
ok the problem is Outlook unabe to find appopriate PF folder to get the FB info from and to publish as well.
Do the following:

Start> Run> adsiedit.msc  > Configuration > services > Microsoft Exchange > Exchange org name > Administrative group > Exchange 2007 admin group name

right click on it go to properties from the list locate sitefolderserver attribute click edit and just copy it and cancel it.

now again go to

Start> Run> adsiedit.msc  > Configuration > services > Microsoft Exchange > Exchange org name > Administrative group > Exchange 2003 admin group name

right click on it and go to properties and find the same attribute Sitefolderserver and paste that value there.

now just dismount and mount Public folder store and open EMC > tool > Public folder management
Expand system folder > expant free busy folder under that you will see one PF folder with the reference of old admin group.
right click that folder and go to properties and go to replica tab and click add and select Exchange 2007 pf store.
if it is already ther just leave it as it is but make sure exchange 2003 store isnt there.

now go tp client machine and start > run > outlook /cleanfreebusy

now you will be able to see this users FB info, and eventually FB info for other users will start reflecting.
hmmm  your Global catalog server is offline or exchange is not able to communicate with your global catalog server .  verify that "s2k3aimdc1" is online .
and that it is pingable . Exchange  requires a global catalog server .
you can setup /preparedomain to take care of that permission issue and that can also cause issues ith FB.
s ait

Author

Commented:
can you explain /preparedomain? Do I just run that from the cmd prompt? and do i actually need to run it?
I am reading about the system attendant and it seems like it provides the free/busy info? Can I just restart the service during work hours? What else could it affect if I do?
s ait

Author

Commented:
Narayan---when I went into asdiedit I dont see any configuration option...this is a Windows 2k8 server which has exc 2007 on it
please make sure that your global catalog server is online . free bussy info requires a global catalog server . and system attendant will keep failing if Global catalog is off
s ait

Author

Commented:
adiloadio: the s2k3 box is turned off, s2k3aimxx used to be the old DC, we since migrated it to a new 2k8 server and moved the fsmo roles over and decom'd s2k3aim as well.
s ait

Author

Commented:
how can I verify that global catalog is on the new server and that system attendant is pointing to it?
GLOBAL Catalog is a domain controller in your environment which holds all objects information . in your case "s2k3aimdc1"  .  ping that server on your network from the exchange server and see if your able to connect to it . if that server is offline then your free bussy data will not replicate .
s ait

Author

Commented:
Thanks, but s2k3aimdc1 has been turned off and removed from the domain...I thought we had moved the GC to the new 2k8 server....any way to verify it and point the FB to the new 2k8 server
Open the  EMC for exchange 2007 , click on Organisation Configuration.

On the left hand side Actions Tab click on Modify Configuration Domain Controller and see if it is poiting to the new domain GC domain controller.

s ait

Author

Commented:
It is pointing to the new 2k8 server..but i want to verify that the new 2k8 server IS the GC
1.Open Active Directory Sites and Services. To open Active Directory Sites and Services, click Start, click Administrative Tools, and then click Active Directory Sites and Services.
2.In the console tree, click the server object to which you want to add the global catalog or from which you want to remove the global catalog.
Where?
Active Directory Sites and Services\Sites\SiteName\Servers
3.In the details pane, right-click NTDS Settings of the selected server object, and then click Properties.
4.Select the Global Catalog check box to add the global catalog, or clear the check box to remove the global catalog.
s ait

Author

Commented:
Narayan...I went to the location you mentioned abve and there is nothing set next to sitefolderserver, it says <notset>
s ait

Author

Commented:
adiloadilo; the new 2k8 server already had global catalog checked..
s ait

Author

Commented:
Narayan...also, when I go to public folder management under toolbox, and right click on the old group under Schedule + Free Busy I dont see an options for Properties
 
s ait

Author

Commented:
Narayan...I was clicking in the wrong place, I went into properties and replication tab and it does show the new windows 2k8 server
s ait

Author

Commented:
Just noticed....free/busy is available in OWA, so its just not visible in outlook
I am not sure why you are looking at the PF's. You need to check PF's only if the users are using OL2003.

If the users are using OL2K7 then Free/Busy information is pulled from the IIS of the Exchange Server with the help of Autodiscover service.
For free/busy to work, it is important you check if Autodiscover is working internally or not.
Simple way of checking it is:
Launch OL2k7 ---> Press CTRL and (+) Right click on the OL icon in bottom right hand side (System tray). Select 'Test Email Autoconfiguration' and then uncheck the 2nd and 3rd check box and run the test.

If you get the result's then Autodiscover is working internally and if not then you need to fix this first in order to get free/busy working.

P.S: The above steps are mentioned assuming all your users use OL2K7/OL2K10. If not then you need to continue working on the PF's.

Let us know how it goes.
s ait

Author

Commented:
Yes, the autodiscover service is not working...what can we do to fix it?
Easy way around is to try and reset the virtual directory to the basic settings. To reset we can re-create the virtual directories. Run the following commands from the Exchange Management Shell:
Remove-AutoDiscoverVirtualDirectory -Identity "CAS_SERVER_NAME\Autodiscover (Default Web Site)"
New-AutodiscoverVirtualDirectory

Once this is done, re-open OL and run the test email autoconfiguration test.

Let us know how it goes.
s ait

Author

Commented:
Looks like the out of office stopped working around the same time...seems like it is all related to the autodiscover
s ait

Author

Commented:
lasotolast...that did not seem to fix it, any other suggestions?
s ait

Author

Commented:
actually, seems like we did not rn that comment yet (I had asked someone to try it)...can we run that command during the day in production?
s ait

Author

Commented:
One interesting thing...we are running in cached mode here (just for fyi)
When I logon with a user for the first time on a brand new pc... his free/busy works on the new PC, just not his old/current one (I even tried recreating the .ost and his profile from scratch with no success)
s ait

Author

Commented:
Turns out it was something to do with a proxy! Details to follow....
s ait

Author

Commented:
This helped lead me to the proper resolution, thanks