New Windows 7 Home Premium Can't Access Shared Files on Network

Fred Marshall
Fred Marshall used Ask the Experts™
on
I recently did a clean install of Windows 7 (Upgrade) Home Premium to try to resolve printer install problems.
All seemed to work OK.  I installed one of my shared printers at home office and that worked fine.
 until:
I introduced it via wireless to an office network
Now, I can't get to any of the network shares without "Enter Network Password" dialog coming up!!
This is unsat.  None of the other computers on the network (all XP) do this.
I have turned off the local Guest account.
I have set LmCompatibilityLevel to 2 and also had tried 1.
What's next?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Systems Specialist
Commented:
Check through this article:
http://www.howtogeek.com/howto/windows-7/share-files-and-printers-between-windows-7-and-xp/

If you still have issues, please post and I'll try to help.

Commented:
Go to Control Panel\User Accounts\Credential Manager and configure credentials for your shares

Author

Commented:
nimatejic: I've done all the standard things.  The Windows 7 computer sees all the other computers, is on the same workgroup, shares are set per the article, etc.
When I open another computer's files from the Win 7 system, I get a logon dialog with username and password required.  
I have found that the username: Administrator and the password for the *other* machine will give access.  But that same other machine doesn't require this of other XP machines - so why the Win7 machine?

SerhiyKo:  I'm not there right now.  This is Win 7 Home Premium and not sure it has that interface....  

Note: I'm not so worried right now about sharing files that are on the Win 7 machine.  The issue is accessing files *with* it that are on other machines on the network.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

NikSystems Specialist

Commented:
Hmm, try to create the same user on Windows 7 as the one you're using on XP when you're trying to access the files on Win7.

Author

Commented:
As I said, I'm not trying to access the fiels on Win7.  It's the other way around.
And, if there were multiple computers on the network (when isn't there?) the suggested idea would be way too cumbersome it appears.  Well, maybe unless multiple users could be logged on at the same time but that ain't Windows is it?

Commented:
fmarshall:
You should have \Credential Manager even on Home Premium. Just check if credential have been cached by Windows. If not, you can create the enrty manually.

Author

Commented:
Yeah, well I don't *want* to do it that way    :-)

Why is it that this works on other networks just fine without this annoying login popup?  That's what I want......
Commented:
It appears that Windows XP/Vista/7 HOME editions cannot save passwords for network shares.

See this post for example:
http://superuser.com/questions/161/does-windows-7-home-premium-remember-network-share-passwords

Author

Commented:
Well, I must be missing something because I've never encountered a situation where file sharing was so restricted.  Not with XP Home, Vista Ultimate or Windows 7 Pro or any odd variety of combinations of XP and beyond Windows systems.  So, this is a limitation of Windows 7 Home Premium?

Commented:
Let me ask you this, what are the exact steps you are following to map a network share?

Author

Commented:
I'm not trying to map, just access.

Commented:
It is my understanding that Home editions of Windows do not support the option of saving network passwords.

Author

Commented:
Well, that's very interesting but it raises a key question.
(Also, I notice that I didn't mention that the shared files are on a Server 2003 system.)
I have lots of XP Pro computers in various peer-to-peer networks.  They share files like crazy.  And, I have never had to enter a password to *be* remembered for this to work - even as we introduce new computers including Windows 7 Pro computers.

So, I don't see how the "remembering passwords" comes into this.

Author

Commented:
In one peer-to-peer network, all the computers have the same password for the Administrator account - but this isn't the only network that seems to work without passwords and the Administrator account on this one is almost never the one that's logged into.
OK, for starters you need to understand a big difference between XP and Vista/7; that being the administrator account is disabled by default so you are not an administrator.  You might think you are; but, unless you specifically enable the administrator, you're not.
Stemming from that, the problem is most probably on the XP systems as they are set not to allow blank passwords. Read this: http://www.theeldergeek.com/blank_password_network_access.htm
I'll bet it will fix your problem.

Commented:
fmarshall,
One quick question that might raise some ideas.

Did you say, this one Win7 computer has been on your own Personal Network, but then Also on someone else's (meaning you don't control it) Work network?

you mention
I have set LmCompatibilityLevel to 2 and also had tried 1.
however those are the most strict.
try level 5.

http://support.microsoft.com/kb/304040

I'm not sure you are going to get around that Login issue, if you don't have a Guest account access.

I see in Win7home premium, if you type Credential Manager in the Start -> Search you'll find the manager.

Author

Commented:
This is still a puzzle for me.  Either I'm being thick-headed or we aren't exactly on the same page yet.....

Commented:
Sorry, as  I read your postings, I gathered that the Constant  Logging in Request from the Win XP Shares when accessing from Win7 machine was what your issue is.  Did I misunderstand?

You mention that you can Access winxp once you provide Admin Account and password. But you seem unwilling to believe that Microsoft finally got it right with Sharing.  It shouldn't be Automatic and without some kind of authentication and unfortunately I don't have a winxp on my network to test this against.  Maybe I'll get one online tomorrow. However  I'm thinking you'll need to blow almost all your security away to make this happen the way I think you want it to.

Commented:
Can you give us a breakdown of your exact Network?

What machines, OSes, Router model, or switches, numbers of each?

Author

Commented:
6 Windows XP Pro
1 Windows Server 2003
1 Windows 7 Home Premium

Connected through a Linksys 8-port switch.  Nothing unusual there.
Internet connection via a Linksys router also connected to that switch.  Also nothing unusual.

The Windows XP Pro machines all access files on the Server just fine with no logins required to see the files.
Not the Windows 7 .....

OK, for starters you need to understand a big difference between XP and Vista/7; that being the administrator account is disabled by default so you are not an administrator.  You might think you are; but, unless you specifically enable the administrator, you're not.

Stemming from that, the problem is most probably on the XP systems as they are set not to allow blank passwords. Read this: http://www.theeldergeek.com/blank_password_network_access.htm
Once you have set that option, you can either add the everyone group to the shares on the XP systems or create a user login that matches the Windows 7 username and hide it using TweakUI ( http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx )

Author

Commented:
.... there is *no* problem with the XP systems ....
Commented:
Let's try this on the win 7 machine cause I'm not how you have yours set up.
1. Click Start
2. Under you user picture, right click Network
3. Choose properties (this opens Control Panel\Network and Internet\Network and Sharing Center)
4. Click Choose homegroup and sharing options in the lower list (this opens Control Panel\Network and Internet\Network and Sharing Center\Homegroup)
5. Click Change advanced sharing settings... (this opens Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings)
6. The setting right before the last one is: Password protected sharing!
7. Choose Turn off password protected sharing and you are good to go without any restarts and stuff.

I haven't had  time yet to put xp on my network, but will try over the weekend.
fmarshall,
You missed the point.  Until you disable the password requirement on the XP computers, you will always have to provide a password to access them from any other operating system (Windows 7 is a different O/S) and; because you cannot be the administrator on Vista or 7, you cannot circumvent that policy.
Understand?

Author

Commented:
I've closed it with points as I have limited ability to revisit the situation.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial