We help IT Professionals succeed at work.
Get Started

Can't publish base CRL...File already exists

2,788 Views
Last Modified: 2013-12-04
I have a script running weekly on a Windows 2003 Certificate server that recreates our CRL and publishes the new crl. It is defined as follows:

@echo off
certutil -CRL
c:\scripts\sleep 5
copy /y %windir%\system32\certsrv\certenroll\*.crl c:\crldata
copy /y %windir%\system32\certsrv\certenroll\*.crt c:\certdata
certutil -dspublish -f -v "c:\windows\system32\certsrv\certenroll\abc.crl" > PublishCrl.log

When the "dsPublish" command runs it generates the message:

Certificate Services could not publish a Base CRL for key 0 to the following location: C:\WINDOWS\system32\CertSrv\CertEnroll\abc.crl. Cannot create a file when that file already exists. 0x800700b7 (WIN#@/HTTP: 183)

When I run the "dsPublish" command manually it comes back and says "Base CRL added to DS Store" Certutil: -dsPublish command completed successfully.

I just added the "-v" switch and the pipe to the log file today so I don't have any output from this yet. What do I need to do to fix this?

Thanks.
Comment
Watch Question
Cryptographic Engineer
CERTIFIED EXPERT
Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE