No link on SonicWall 3060 Interface When Connected to Cisco 2821 Router

fireguy1125
fireguy1125 used Ask the Experts™
on
Need to connect a Cisco 2821 Router to my Sonicwall Pro 3060.  I have enabled the interface X4 as a DMZ, assigned a static IP, however when connected to the Cisco Interface, No link is shown.  When powering on the Cisco, the link comes up briefly, but then shuts down.

I plugged in the Sonicwall X4 interface to a switch, and I get a link.  I plugged in the Cisco GE 0/1 interface to a switch and get a link.  The problem is when the two are plugged into each other, I don't get a link.

I have tried this with both a straight cable and a crossover cable.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Does it work if you hard-code a speed/duplex on the link/ Do you get any log messages about it in the Sonicwall or debug output from the Cisco? Whats the output of the sh int gig0/1 on the Cisco when it's plugged in and not lit up?

Author

Commented:
I don't know about the Cisco log outputs or settings, it is a hosted router with pre-configured settings, which I don't have access to the interface, which are supposed to be 100/Full, so the Settings on the Sonicwall Interface is all 100/Full.  I also tested Auto and it didn't come up.
I would enable all of your logging categories in the Sonicwall then, do the unplug/replug and see if anything shows up in your log. If nothing shows, try connecting to the console port using the supplied cable and post the output of show interface details x4 and show interface status x4.

When you connect the console to your computer use Hyperterminal and set it to 9600 bps, 8 bits, no  parity, no flow control. Here are more details on hooking up the console:
http://www.fuzeqna.com/sonicwallkb/consumer/kbdetail.asp?kbid=6180&SearchType=advanced&referrer=&gpn=&CustID=&bUseEditor=&keyword=cli&rfield=&sortmethod=rel&usertype=&gpv=&catID2=&formaction=search&catID1=&IncludeHTML=&catID3=&TotalResults=4532&submitbutton=Go&match=and

Here is the SonicWALL CLI Guide as well:
http://www.sonicwall.com/downloads/SonicWALL_SonicOS_CLI_Guide.pdf
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

Author

Commented:
Thanks crouthamela, I enabled all logging and nothing, didn't get to do the hyperterm though.  I did contact the provider of the hosted router to verify the settings, and they advised me that it was set to 100 full with protocol down (no arp).  When they set it to auto/auto the protocol went up.  They resolved it to 1/2 duplex and speed 100.

Only question I have now is, that since they set to 1/2 duplex on their cisco interface, should I set the interface on the Sonicwall to 1/2 duplex as well?
Yes, you would want to match their settings.
Thanks for the points, I'm glad I could help!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial