Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

08 Jul 10 09 - Powershell - TS Home Directory

Avatar of nordtorp
nordtorpFlag for Norway asked on
Active DirectoryProject ManagementPowershell
7 Comments1 Solution1800 ViewsLast Modified:
Sirs,

I have a rare problem.

Background:
I have set the TSHomeDrive and TSHomeDirectory property of a user at a Windows Server 2008 through PowerShell (v2.0).
I use Quest ActiveRoles Management Shell cmdlets to make these changes. This is the command I run:

Set-QADUser $id -TsHomeDrive "H" -TsHomeDirectory $TSHome

Problem:
When I try to login to a TS with this user the home drive is not mapped.

Workaround:
Open the user AD object and set TSHomeDirectory to Local Path, then set it back to Connect. Log back in.

I am looking for a way to get this to work by just setting these settiings in PowerShell. The domain functional level is 2003, but the command ran from a 2008 AD controller (still 2003 functional level)

Please ask for more details relevant to this if you feel I left something out.
ASKER CERTIFIED SOLUTION
Avatar of gtworek
gtworekFlag of Poland image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 7 Comments.
See Answers