Exchange hosting not receiving mail

Cheryl Lander
Cheryl Lander used Ask the Experts™
on
We have just moved our in house exchange server to a hosted service with rackspace.

Everything seems to be going fine with mail other than the following.

I have replaced the sensitive information.

Hi. This is the qmail-send program at server.servername.com.au.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.


<mail@domain.com.au>:
00.00.000.00 does not like recipient.
Remote host said: 553 sorry, that domain isn't in my list of allowed rcpthosts; no valid cert for gatewaying (#5.7.1)
Giving up on 00.00.000.00.

So here is the issue.

we can receive email to the new exchange server from Yahoo, Google etc.
but we cannot not receive email from a web hosting service we manage.

Ive contacted rackspace and they say that it may potentially be an issue with the DNS has not resolved has yet.

Any ideas would be great.

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2018

Commented:
The error message is pretty straightforward; qmail (a unix mail program) answered the SMTP request and then rejected the connection because the domain was not on its list of accepted domains.
Could be DNS if mail is going to the wrong server, could a problem with rackspace.
Without domain names and expected IP addresses, we are blind to troubleshoot DNS issues.
And rackspace issues are their own; there is a reason you pay them for hosting.

Author

Commented:
Ok so to rule out dns I have to wait correct? currently been 24 hours. I am aware that it takes up to 72 hours, but as everything else worked I just assumed all was ok.

but that wouldn't not explain how yahoo and gmail mail gets through ok...

Commented:
Sounds like the external DNS has propogated so outside services are sending mail to rackspace.

Do you have internal DNS MX entries still present for your qmail server? Wherever your managed web hosting service is must have an MX entry that still points to your qmail.
Top Expert 2010

Commented:
Hi
lets try tihs

a) Go to www.testexchangeconnectivity.com
and enter your domain name.

Lets see what that throws-up.
Distinguished Expert 2018

Commented:
The way DNS works is that it is decentralized. Yahoo and Gmail have different DNS servers, so your DNS changes may have propogated to their servers, where is the problem sender may still have old references. How long you'll have to wait or how long old records stick around is called a TTL and every record has one, that is also set by the administrator/DNS controller. If you know what that TTL was, that is how long you'll have to wait. If you don't......may be worth pursuing another course of troubleshooting.

Author

Commented:
Have tested inbound at www.testexchangeconnectivity.com and all seems fine. no reference the the ip listed above.

TTL was at 300.

tniemetz:
looking into this now.
I know we did have a backup record.
Distinguished Expert 2018

Commented:
300 what? Seconds?!?!?

Author

Commented:
yes sorry.
Top Expert 2010

Commented:
Can you check your outlook Settings ?
Is SMTP authentication turned on ?

what version of outlook are you using ?
Did you install it by running the auto configuration utility from rackspace ?
Distinguished Expert 2018

Commented:
I'm hoping that you don't *always* run your DNS servers with 5 minute TTL records. Was this cranked down as part of the migration plan? If so, what was it originally? And was it changed with enough lead time that the TTL itself was allowed to refresh? Changing a TTL to 72 hours to 5 minutes means the old TTL itself could be cached for 72 hours, so making a record change only 24 hours later, for example, means that the 5 minute TTL is ineffective in most cases...
Distinguished Expert 2018

Commented:
As I said in the beginning though, I don't think this is DNS....it just doesn't "smell" like it. Worth looking into, but I wouldn't lose sleep over figuring out if this is DNS related.....
Was the old server *AND* the new hosted server both Exchange?

Author

Commented:
Can you check your outlook Settings ?
Is SMTP authentication turned on ?
How can you check that on an exchange account in outlook? issue is people sending to me.

what version of outlook are you using ?
2007
Did you install it by running the auto configuration utility from rackspace ?
Yes. had support check settings.

TTL isn't always at this level. normally much higher. was set before migration.

Author

Commented:
cgaliher: yes both were exchange.
Top Expert 2010

Commented:
Do you have a Backup MX set up ?
Where is that going to ?
Distinguished Expert 2018

Commented:
Curious. It bothers me that qmail is responding then. Again...the smell test.....do you (or did you) have a 3rd-party antispam/AV solution in place, hosted or otherwise?

Author

Commented:
The ip address thats hidden in the email.
This si the only reference i can see that could cause the issue.
Top Expert 2010

Commented:
And where is this qmail responding from  ? On-premise / Hosted / Backup MX / ISP
Top Expert 2010

Commented:
Go here
www.mxtoolbox.com/

Check how many MX records are listed for you.
that will give you a clue for backup MX

Author

Commented:
Yes.

So the email response is coming from IP 0.0.0.0

But it shouldnt be going there as its now pointed to rackspace.

0.0.0.0 is where the backup was located. but all dns is pointed away from it.
Distinguished Expert 2018

Commented:
After re-reading, I may even be misunderstanding the issue. This is a common problem when an error message is "over" scrubbed. Hiding server names is all well and good for security, but hiding domain names usually doesn't help because...well...your domain is already out there from the moment you purchased that name from a domain name registrar. There is *no* protection in scrubbing it.
Don't get me wrong, I see people do it all the time, but if you *do* continue to practice that, you may want to use some "fake" domain names that more clearly indicate which domain is your old one, which is your new, and which is perhaps a 3rd-party.
In particular, I re-read the initial problem and have a question about the following:
Hi. This is the qmail-send program at server.servername.com.au.
Is "server.servername.com.au" the server that has the "web hosting service" you manage?
Top Expert 2010

Commented:
Verify Backup MX location from here
www.mxtoolbox.com/

for some reason I think the emails are hitting your backup MX because your TTL is low
then it gets the qmail error - because backup MX was removed from there ?
(what was removed - the email server or the MX record ?)
Top Expert 2010

Commented:
Yeah
To second cgaliher's point..that info will help
http:#33122629

All IP specific information can be fudged by the moderators when the case is closed.
You can do it yourself by clicking on rEquest attention on top or contacting any of the zone advisor's on exchange
http://www.experts-exchange.com/communityService.jsp?editVolunteerMenuIndex=3

Author

Commented:
repost...with info

Hi. This is the qmail-send program at dv.sydneywebhosting.com.au.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

:
xx.xx.xxx.xx does not like recipient.
Remote host said: 553 sorry, that domain isn't in my list of allowed rcpthosts; no valid cert for gatewaying (#5.7.1)
Giving up on xx.xx.xxx.xx.

Author

Commented:
ab.abc.com. = our web hosting service.
xx.xx.xxx.xx. = ip of our web hosting service.
So I sent an email from inbox@def.com to inbox@abc.com and got the qmail error message.
Distinguished Expert 2018

Commented:
And to be clear, fusedmedia.com.au is the domain name for the exchange server that has been relocated to rackspace?

Author

Commented:
Yes. hold on a sec. just got an email from the it guys. (I know this isnt a chat)
Commented:
The message looks a lot like a relay issue - you may need to add abc.com to the allowed relay domains in the qmail config on the sydneywebhosting server.
Distinguished Expert 2018

Commented:
Perfect. Barring some variable I've missed, I am now fairly confident that this isn't a DNS or backup MX issue, or even a rackspace issue (unless your web hosting service is also at rackspace...)
This is a problem with the configuration of qmail (a linux email program) on the web hosting service server. It has been locked down to only send to specific recipients....probably by IP instead of by domain name....and thus it does an MX lookup, gets the IP of the new location of your server which doesn't match its IP address filter, and throws the failure. You'll need to adjust that (if you have access) or work with the hosting service to adjust it (if they hold that control.)

Author

Commented:
Issue resolved.

found a qmail smtproutes file

edited and all good now.

Thanks very much guys.

I will go through now and allocate points.

Ive got one more question regarding this. will be up in 5 mins.
Top Expert 2010

Commented:
I think these 2 are close to the solution
http:#33122738
http:#33122741

Since you are running your own hosting env. I think you can change qmail settings etc.
can you verify cgaliher's assertions and let us know.
Top Expert 2010

Commented:
That was Quick !!

Author

Commented:
Will post official answer when I hear back from it guys.

Commented:
I'll give a shout to cgaliher for the early call on non-DNS. I thought it reeked of DNS until I saw the relay error.
Distinguished Expert 2018

Commented:
Thanks tniemetz. This stuff is half intuition and voodoo, as I'm sure you know. If I had read this yesterday or tomorrow, I probably would have thought DNS too (it certainly has the cursors!) ....sometimes, y'just get lucky.   :)

Author

Commented:
OK Guys here it is.

Tell EE that there was an old smtproutes file in /var/qmail/control pointing abc.com to mail.abc.com, eg telling qmail not to deliver mail locally.  Could have been there since the server was setup (purchased).  It was dated around January 29 this year.

The second rcpthosts file that we added was not in there - overwritten long ago when plesk changed settings the first time after we set it up.

Any help in allocating points would be appreciated.
Distinguished Expert 2018

Commented:
EE as an entity doesn't really know or care about the solution. You documented it which is "good enough" for future problem searchers to decide if their problem matches yours and if your solution could apply. So...no need to notify EE of antyhing. You've done that step.  :)
As far as points goes, that is your decision to make. They are your points, allocate them how you see fit, who you feel was beneficial, who helped steer you in the right direction, etc etc. You can split points among as many posts as you want. It's a personal thing, and each person (question poster) must decide what answers and comments were important for themselves.
Top Expert 2010

Commented:
If I am re-reading this case 5 months form now --> this is the solution which will help me figuring this out.
http:#33122741

With confirmation from requestor here
http:#33122802

Author

Commented:
OK Guys here it is.

Tell EE that there was an old smtproutes file in /var/qmail/control pointing domain.com.au to mail.domain.com.au, eg telling qmail not to deliver mail locally.  Could have been there since the server was setup (purchased).  It was dated around January 29 this year.

The second rcpthosts file that we added was not in there - overwritten long ago when plesk changed settings the first time after we set it up.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial