We help IT Professionals succeed at work.

Choppy sound in Windows 7 after resuming from sleep

levidos
levidos used Ask the Experts™
on
Hello,

Lately I'm experiencing problems when playing music both on my office PC and on my home. My office PC is x64 bit while my home PC is x86. What they have in common is an NVidia card (7300 on my home PC while 9600 on my Office PC) and MoBo integrated Realtek Sound Chip. The systems are up-to-date, drivers are updates via Automatic Updates. The choppy sound appears after I resume the computer from sleep. If I reboot the comptuer, the sound will be okay until I sleep it again. Any suggestions?


Best Regards,
Levente Rog
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Windows automatic updates are limited to their software, not your hardware and even computer manufacturers do not post the latest drivers. Go to the realtek site and download their latest drivers, then go to the mobo site and find the latest drivers for controlling the power settings.

Author

Commented:
Thanks nwtechdesk for your prompt answer. Should I download drivers from Realtek or from Intel's website?
Please find the screenshot attached.
soundcard.JPG
Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
i know this sounds out there, but you might do well to run a defrag (http://www.piriform.com/defraggler)

if your files are extremely fragmented it might just be too busy to play normally

Author

Commented:
bryon44035v3, I use SmartDefrag to defragment my computer regularly.
I've just dowloaded Realtek's latest driver as nwtechdesk suggested and wait to see if the problem appears in a few days.

Author

Commented:
Updating the sound card driver to Realtek's latest version did not solve the issue.

Author

Commented:
Please don't delete the post.. I think I have the solution, just want to test it out properly.

Levi

Author

Commented:
Please don't delete the post.. I think I have the solution, just want to test it out properly.

Levi
Commented:
According to Microsoft Forums, the solution is the following:

Click your start orb, type "services", press enter, find and restart the "Microsoft Antimalware Service".  Turn real-time protection back on if it's still off and was on before.  Check your sound, and it should be fixed!

Source:
http://social.answers.microsoft.com/Forums/en-US/w7music/thread/292b7b54-140a-48b6-9372-ec0e8b4a773d/

Best Regards,
Levente Rog.