We help IT Professionals succeed at work.

Command Prompt TAB Auto-Complete not working

garryshape
garryshape used Ask the Experts™
on
When I'm in the command prompt on Windows XP, and I'm in a directory where I know a file name or folder exists, if I type the first letter or so then hit TAB, it does not auto-complete the folder or file name, it simply inserts a TAB in the line.

I tried changing HKEY_CURRENT_USER\Software\Microsoft\Command Processor value to 9, but that has not fixed it.

Is there any other fix for this or an alternative command prompt GUI I can download to use?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
can you provide a screenshot of your registry window, in that location?

also, did you close any open command prompt windows and then re-open one?
Hi,

Check in "HKCU\Software\Microsoft\Command Processor" if "CompletionChar" is a "REG_DWORD" type and value is 0x00000009 (9).

Paste the text below in a blank text file, save as ".reg" extension and double click it.

--- complete.reg - copy and paste below this line --
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
"CompletionChar"=dword:00000009
"PathCompletionChar"=dword:00000009
--- complete.reg - stop copy and past on up line --

If you wich use a gui, open a console window (cmd.exe) and click in window icon in title bar, choose "Defaults", go to Options tab and check AutoComplete. Click in "OK"

Author

Commented:
Here's a screenshot of the registry.

I also tried changing "PathCompletionChar" value to 9 but no luck there.
registry-cmd.png
Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
how about what andrey said above:

If you wich use a gui, open a console window (cmd.exe) and click in window icon in title bar, choose "Defaults", go to Options tab and check AutoComplete. Click in "OK"

How you start the console? Typing cmd.exe or cmd in start/run dialog or double click in a shortcut icon?

If is a shortcut: Right click, properties, and check if in target has "/E:OFF" or "/F:OFF".

If you start typing cmd.exe in start/run dialog, try start typing "%windir%\system32\cmd.exe".

Check if CompletionChar, PathCompletionChar and EnableExtensions values are 9, 9 and 1 in "HKCU\Console", "HKCU\Software\Microsoft\Command Processor", "HKCU\SOFTWARE\Policies", "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies" and subkeys if exist.

You can try rename "HKCU\Console", "HKCU\SOFTWARE\Policies", "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies", except "HKCU\Software\Microsoft\Command Processor" and try work in this key only.

Console need to be closed before modifications in registry or modifications are lost when closed.
I´m wrong, you not lose registry modifications when console is closed, but you need open new console to test. The modifications don´t applies a opened console window.

Author

Commented:
@andrey2010
I tried saving that reg file and importing, but when I open a command prompt still nothing. I checked for the registry entries you mentioned under HKCU\Console, but they do not exist.

Before I keep at the registry, I will answer your other question: How am I opening the command prompt?

Answer: I either go to start > run and type "cmd" and hit OK, or I open my QuickLaunch shortcut. The QuickLaunch shortcut target is "C:\WINDOWS\system32\cmd.exe" and says Start In: "C:\Program Files\Windows Resource Kits\Tools\". There is also no /E switches or any other switches on the shortcut.

And Which ever way I open, I do not see any Options. Screenshot of what I see below/attached.

Author

Commented:
Screenshot of CMD options.
mi1cuq.png

Author

Commented:
I changed the directory under "Start in" for my Quick Launch shortcut to C:\WINDOWS\system32\ and this seems to have fixed the tab issue.

Author

Commented:
These solutions are valid but I had to change shortcut settings first for my command prompt. See screenshot and previous post.