We help IT Professionals succeed at work.

Outlook 2007: Stop prompts for internet shared calendar login

DeepThnkr
DeepThnkr used Ask the Experts™
on
Outlook 2007 has an internet shared calendar feature. Users are being prompted to log in, even though they have never shared their calendars.

"Please enter your username and password for publishing calendars to calendars.office.microsoft.com."

In tools|accounts, we can delete the item on the internet calendars menu - but it reappears after outlook is reloaded.  Apparently you used to be able to go online and change your subscription, and now it is done through the client by right clicking on the Calendar and going to publish to internet.  But the remove from server item is greyed out.  (They have never shared it to begin with)

At this point the feature has become more trouble than it is worth. What I would like is to find some way to disable the feature entirely on a case by case basis.  I don't see it in the options, or under the add-ins.

I suspect, but have not verified, that another user with a shared calendar has logged in to the machine under an administrator account (me). Somehow the internet calendar feature is active under the regular user's profile, but has not been configured with a web login.  (Or perhaps the login credentials are blown away when the internet items are cleared periodically.)

Any quick way to disable this annoying thing? Or even fix the problem?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Do you have the same pb in outlook safe mode ? Outlook.exe /safe
Top Expert 2012
Commented:
Right Click on the Users Calendar
Go to Publish to Internet
Select Publish to Office Online
Select the Advanced Button

Change The Upload Method to Single
Remove the Tick under Update Frequency, which updates according to Server Settings
OK and OK
If it asks you to log on click cancel
This will still retain the settings you just changed

Also Check Publish to WebDav Server
When looking at this option
Is there anything in Location?
If there is delete it.

Apply, OK

Now check the Internet Calendar under Account Details
Tools>Account Settings>Internet Calendars
If the calendar is still there, now delete it
Apply Ok

Restart outlook

Should be okay now




Author

Commented:
Hi apache09,
I found the options you mentioned except for WebDAV - where is the menu item located?
Thanks - this looks promising...
The second issue will be why account settings from my profile are getting connected to other user's accounts...
(Like my RSS feeds, and this synchronizing thing)  I am the only user who has permission to log in to another
user's mailbox?

Author

Commented:
So the prompt is back today.  But the frequency of it is much lower.  So generally a big improvement, but not totaly fixed.
Found the webdav option under Publish to Internet | Publish to webdav server.

Author

Commented:
The annoying prompt still comes back, but this allows me to reduce the frequency of the issue.