We help IT Professionals succeed at work.

Reverse DNS (PTR) record for Mail Server with local DNS name

abc_mhorn
abc_mhorn used Ask the Experts™
on
I am having  a problem with our Exchange 2007 SP1 email server getting outbound email rejected by a few external companies' email servers.  The reason they are being rejected is because our PTR record does not match the domain name our mail server presents in the HELO .  

Our internal DNS domain is different from our public DNS domain.  We use mycompany.local for our internal DNS space and mycompany.com for our public DNS space.  

Our PTR record with our ISP points to mycompany.com.

The hostname of our mail server is hostname.mycompany.local.

It was by design that we separated public and private DNS spaces.  With more companies combating spam by validating PTR records, I'm not sure what options I have to remedy this problem so email sent from us gets through to email servers that do reverse DNS checking.

If I configure the PTR record for mycompany.local this is technically wrong because mycompany.local cannot be resolved publicly.  

I can't change the hostname of the Exchange server but if there is a way to change the name Exchange presents in the HELO greeting, I am afraid it will cause issues for my end users who use Outlook.

Does anyone have a suggestion to resolve this problem so email from our system will be delivered to email servers that do reverse DNS checking?  Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
go to the properties of your send connector
update the specify the fqdn this connector will provide
or you could use the set-sendconnector <connector name> -fqdn smtp.contoso.com
Robin HumanHead of Network Services

Commented:
Make sure that your MX record points to the correct address, and enable forwarding to the correct mailserver IP address

Author

Commented:
I think the solution suggested by endital1097 will do the trick.  I'll look at this tonight to see if it works.  

Just to be certain, will changing the fqdn on the send connector cause any issues for clients connecting using Microsoft Outlook or Outlook Anywhere?
no, they connect to the receive connector

Author

Commented:
OK.  That makes sense.  I'll look at this tonight and post back with my results.  I think this will solve my problem.

Author

Commented:
Thanks for your help.  This resolved our issue.