We help IT Professionals succeed at work.

Mouse freezes on Windows 7 at Login Screen

stpracer
stpracer used Ask the Experts™
on
Hello Experts!

We recently started to deploy Windows 7 machines onto our school network. We have a Windows domain running Windows Server 2003 R2. When logging off or switching users, the monitor will lose signal, turn black for 12-13 seconds then return to the login prompt.   At this point, the mouse freezes and will only work after powering down the system or reconnecting the mouse.  The mouse problem only occurs with USB mice, not PS/2.  USB keyboard is unaffected.

After some troubleshooting, we found this problem only occurs when switching domain users or logging off of a domain user account. When switching or logging off of local user accounts, the problem does not occur.

All recent Windows updates are installed and we've updated hardware drivers and the BIOS.
Any ideas would be greatly appreciated.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
This is odd and something that seems to have plagued both VIsta and Windows 7.

Try this on once machine after backing up the registry.
http://windows7themes.net/mouse-not-working-after-hibernation.html

Try 2 first and then 3.
Is there a batch file that runs with a domain user logs out?????????????  It sounds like that is the culprit since logging on isn't it.

Commented:
Switching a user would not start a log off script.

Commented:
This was a problem with Vista, and I think carried over to WIN 7.

http://support.microsoft.com/kb/930091

Author

Commented:
Hello all,
Unfortunately we tried the steps outlined in both articles but neither fixed the problem.    We did notice that when the machine was not actively connected to the network (network cable unplugged), the problem did not occur.

We then checked for and disabled the logoff script that runs and reconnected the network cable.  This too did not fix the problem.
Joseph MoodyBlogger and wearer of all hats.

Commented:
Can you upload an RSOP report of a computer with this problem?

Commented:
This is only for a few users and not company wide correct.

Author

Commented:
Jmoody10:  I'm waiting for my supervisor to ok the upload.  We'll let you know one way or the other once we hear something.

snurker:  Correct, this only happens with members of our "Administrators" domain.  With all other domain users, the problem does not occur.

ChiefIT:  We tried installing the file outlined in the article however the problem persists.


Thanks to those have replied so far.

Author

Commented:
Good morning all!

Sorry for the long delay but I have attached the requested report to this post.  During last week, we discovered that this problem is occuring with another subdomain within the district.  I've attached reports from both subdomains.

Thanks again.
GPReport-Subdomain1.html
GPReport-subdomain2.html
I'm having this issue as well with one minor difference. It only happens when I have a Linksys wireless adapter connected at the same time. I've tried all kinds of different mice. I've only tried it on a new shipment of Dell Optiplex 380 PCs. So, I'm not sure if it's something related to the hardware in that model and the Windows 7 driver for this device, or if it's a more general Windows 7 issue. Any help would be appreciated.

Author

Commented:
No solution yet so we're not much help.

Commented:
Sorry, I did not see the response from before. You said your Administrator's domain? Did you mean OU, the folder with the administrator's user accounts? This sounds like ti could be a script running that is waiting for a response. If it is the OU, please post all GPO on that OU.

Commented:
Speaking of which, there is the policy to add printers, this could be an issue, but honestly, I have not seen it mess with UIDs.

You could try disabling the GPOs on only that OU for administrators and see if things change.
I've seen a similar issue with Windows XP boxes, Dell Precision 390 to be percise.
Sometimes unplugging the mouse and reconnecting helped with fixing the issue, but what I ended up doing is going to device manager, select the mouse and then under power options I unchecked the option "allow PC to turn off teh device to consume power", I also updated the BIOS and chipset. Again, this is for XP and not Win7, however maybe there are some similarities between this issue that I had and the issue you are working on. In my case it didn't just freeze at startup, it would eventually freeze while PC is in use. So, even if there is an option in Windows 7 to allow it to disable the device to consume power, I really doubt that this is the problem. Check if there is a driver update for that particular mouse, also check if BIOS update is available and it may actually help. Try the mouse in a different USB port as well.

Commented:
Ohh and BTW, did you check the error logs to verify there was not an IO conflict?
Commented:
As mentioned above. It appears that this is a group policy object for domain users. Since this doesn't effect local users it appears a domain policy may be monkeying with the power save features for the USB bus>>

A Vista/Win7 fix is supposedly found on this link. It seems like a reasonable fix. But, I would have to look at group policy objects that might monkey with power save features. What kind of Group policy objects might do this....

http://www.vistaheads.com/forums/microsoft-public-fr-windows-vista-general/460788-vista-usb-mouse-freezes-fix-windows-7-a.html