Exchange, ATT, and the Static IP

Nathaniel_ScrivNET
Nathaniel_ScrivNET used Ask the Experts™
on
I have recently taken on a local gym as a client that has their own Exchange Server. Recently all ATT email addresses have started to kick back as being blocked. The ISp is ATT.

They have a static IP range, and the gateway IP. If you ping the mail.domainname , it resolves back to the gateway IP, which is  *.*.*.110.

When I called ATT to find out what the issue was, they stated that the gateway IP cannot be used for mail, and that we have to use one out of the blocks of statics. .5 through .9.

This is where I am confused. How do I change the exchange server to use a different IP than what is on the NIC, and is what the tech told me even correct?

I mean this used to work with no issue and now it doesn't. We have no problems sending mail to any other set of addresses.

They also said I would have to submit a reverse DNS request to enable the IP to resolve to the mail. address.

I am completely lost on this one.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
You may need to modify your send connector to route through the correct address for AT&T.

1. Open Exchange Management Console.
2. Expand Organization Configuration.
3. Select Hub Transport in the left column.
4. Select the Send Connectors Tab in the middle.
5. Modify or Create a new send Connector to route through the IP address AT&T said for you to send mail out of.

You should be fine on the DNS side, but let me know if you aren't.

Thanks

Also if I was incorrect on the Exchange Send Connector you may want to run https://www.testexchangeconnectivity.com/ on one of the problematic AT&T address and report the errors here.

Author

Commented:
I would have to update the dns for the mail. address wouldn't I? Or would the hub connector translate through the gateway IP?

Author

Commented:
I don't see the options you describe in 2003 Exchange System Manager

Commented:
>> How do I change the exchange server to use a different IP than what is on the NIC, and is
>> what the tech told me even correct?

You do this on your network equipment.  If your network equipment/configuration is fairly basic, you can find out what IP your Exchange server has by going to "whatismyip.com" from the Exchange server.  That website will show you what the internet sees as your Exchange server's public IP address (this is assuming you are not doing Port Forwarding or some such on your network gear)

I think what the ATT guy is trying to tell you is that mail.domainname.com should not resolve to the gateway, it should resolve to the Exchange server's public IP.  Make that happen by changing your client's public DNS records.


And, a reverse DNS record can only help.  More and more, you will see email servers refusing to accept mail from servers that do not have a proper reverse DNS record.

Author

Commented:
The exchange server's public IP is the gateway IP, I am being told that we cannot use that and we have to use one of the statics. The IP is the same no matter what machine you check on whatsmyip, because they all go through the gateway.

The question here is how do I setup the exchange server to use one of the statics. I can't change it on the NIC, the network is setup to be a 192. private network.

Commented:
Typically, you set that on your router/firewall.

(Keep in mind that when you purchase business-class internet service with static IPs, you get some static IPs for you to use, so it *is* possible for you to use them.  It's just a matter of setting up your networking gear to help you do so)

What kind of router/firewall do you have?  We should be able to set up the Exchange server to look like it's using one of your static IPs by changing its configuration.

Author

Commented:
I managed to get a firewall that has Multi NAT abilities so that is good to go, and I changed the MX record to reflect the new IP. Now I get an error that says it cannot relay to that IP....


This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

  joleneb@worldgym1.com
    SMTP error from remote mail server after RCPT TO:< joleneb@worldgym1.comm>:
    host mail. joleneb@worldgym1.com [99.1.5.6]: 550 5.7.1 Unable to relay for   joleneb@worldgym1

IP and mail server has been altered to protect the innocent :P


Commented:
That looks weird - were you sending as joleneb@worldgym1.com to joleneb@worldgym1.com, using SMTP?
fixed myself

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial