Solaris 10, quad ethernet port settings

drv35
drv35 used Ask the Experts™
on
Hello,

I'm sure this is an elementary question, but how do I hard set my qfe4 port so it stays at 100/full, no auto, after reboot?  Here's how I set it the first time:

ndd -set /dev/qfe instance 4;ndd -set /dev/qfe adv_100fdx_cap 1;ndd -set /dev/qfe adv_autoneg_cap 0

Thanks,
Dave
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
You can edit /etc/system to preserve those settings.

See http://www.brandonhutchinson.com/Solaris_NIC_speed_and_duplex_settings.html
and http://www.tek-tips.com/faqs.cfm?fid=5832

In your case, you'd be adding lines like:
set qfe:qfe_adv_autoneg_cap=0
set qfe:qfe_adv_100hdx_cap=0
set qfe:qfe_adv_100fdx_cap=1

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial