@ not working in Debian

Rik Van Lier
Rik Van Lier used Ask the Experts™
on
hi i have a Belgium azerty keyboard and when i am in Debian Linux i cannot use the keys under the ALT GR function... for ex, @ and # those keys are on the 3 and 4 on top of the keyboard.

any idea how i can use these?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi!

In the interface with X Window, the command

setxkbmap fr

converts the keyboard into an AZERTY keyboard.

In X, the keyboard interface is completely configurable, allowing each user to assign different functions to each key in line with their personal preferences. For example specific combinations of Alt Gr + key could be assigned to the characters, œ, Œ, æ, Æ, …, ½, etc..

Outside X, in console mode, the following command is used:

loadkeys fr

Regards, Tobias
Doesn't it work to change the keyboard layout under System / Preferences / Keyboard ?
1belgium.gif

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial