I just connected my server to my router but my client machine does not connect to it.

grouchyfd
grouchyfd used Ask the Experts™
on
My server used to be connected to my client machine via crossover cable. I now have the server connected to my router (using a standard ethernet cable), but my client machine will not reconnect to my domain on the server. I would like to have this setup so I can test cleint/server apps using either wireless or ethernet connections to the server. I can ping the server (using the command prompt) on both my client machine and a wireless laptop. I cannot connect like I used to by connecting to the domain. What setting do I need to reset?
Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Has your client machine joined the domain? Is your server handing out DHCP? Is your server now the gateway?

Author

Commented:
I'm not much on server setup. I had someone set it up for me originally. I can't connect to the domain.
Run IPCONFIG /ALL on both the server and client and check to see the network connections. In the previous set up the server should have been you gateway, now the router should be.

Does the server see the client in Network places? Can either one get to the internet?
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
I ran IPCOFIG/ALL on both machines and both see the router. Both do connect to the internet. I noticed that my client has one ip address and the server another. The only thing under Network places are the connections. Both say DHCP enabled & Autoconfiguration enabled.
Hello,
Is a DHCP scope setup on your server? If no follow the below suggestions via network cable from your client PC to your Router.
Firstly ensure that static IP Addresses are configured for your Domain Controller (DC) and that after running IPCONFIG /ALL on your server the DC's DNS IP Address is 127.0.0.1. Also note the Default Gateway IP Address, this can be left blank if no access to the internet is required assuming that your router is also connected to the internet. If internet access is required simply change this to the IP Address of your router.
Secondly ensure that your client PC is using the DC's IP Address for its own DNS Addresses.
Thirdly, most routers are DHCP enabled, meaning that your router will allocate a client PC an IP Address from its own scope which will in turn use the router for its DNS (Which will not have an entry for your domain controller or global catalogue server). Run IPCONFIG /ALL on your Client PC, if it has an IP from your router it is likely to start 192.168.xx.xx. If your Server has an Static IP 10.0.0.1, it will make sense to change your client IP to suit, i.e. use an IP from the same range that isn't being used (10.0.0.2 for example).
In short, allocate an IP to your client PC that is from the same address range, ensure that the subnet mask is the same, use the DC's IP address for your DNS Address, if internet access is required use the IP address of your router for the Default Gateway address.
On your server ensure that static IP's are configured for the LAN Adapter making sure that its DNS Address is 127.0.0.1.
If you are still unable to logon, try to ping the DC's hostname. If successful, you may need to remove and reconnect your client PC to the domain.
Let us know how you get on :)
Michael Ian Claridge
Server Infrastructure Engineer
A HA, just read your post :)
Servers should not be DHCP enabled, this means that you have your server and client using the router for their DNS.
What is the IP config of your Server? I will tell you how to set it up with static IP addresses and how to setup your client PC Network Card.
Cheers
MC

Author

Commented:
What do you need to know abot the IP config? Should I disable the DHCP?
Run IPCONFIG /ALL on your server and post the results :)
We will assign static addresses which will disable DHCP addresses for your LAN card.
Cheers
MC
If auto configuration is enabled and your router is not handing out IP addresses, they may getting APIPA addresses. Depending upon your subnet mask this could cause them to not see each other as well.

range 169.254.0.1 through 169.254.255.254 inclusive

http://msdn.microsoft.com/en-us/library/aa505918.aspx

Author

Commented:
Here is the IP CONFIG from my server.
IPCOFIG.txt
Hello,

These addresses have been obtained from your router.
Configure your IPv4 settings as per screen print attached
Server.jpg
Whoops, wasn't quite finished :)
As your client IP addresses would not have been obtained by your domains DHCP, you may also need to assign static addresses.
Just yell if you need help.
Cheers
Michael Ian Claridge
Server Infrastructure Engineer

Author

Commented:
Do these settings go into the client machines?
Hey,
I've attached an example of what your client config should look like.
Of course these static addresses may conflict with other addresses on your network and will need to be investigated by yourself and an exclusion added where possible.
Cheers
M

Client.jpg
Fisrt screen print is for Server, second is for client.

Author

Commented:
OK on the server side. I tried the client side and I lost the connection to the internet & still can't connect to my server database. Sorry about this. You have so helpful so far. Attached is my IPCONFIG for my client machine.
Client-IPCONFIG.txt
Hey no worries :-) if you look at my last screan print, but you can use 192.168.1.70 instead :-)

Author

Commented:
I have followed you instructions. I have been trying for a while. When I change the client to a static IP address like what you show, not only does it still not connect to my server, I lose my internet connection. I know it must be something simple. I appreciate your time and you expertise.
Using the configuration above, does your server still connect to the Internet?

If so, you are half-way there. Once your server can connect to the Internet by name, see if you can ping the ip address 192.168.1.78. This should be the address of the server and reachable by the client. If not, then your server may not be set up as a DNS server and you need to either configure it as such or use your ISP's DNS servers.

When you have the client configured as DHCP, you can connect to the Internet but not the server? If so, do an IPCONFIG /ALL and see the DNS server addresses. It may be using your ISP's servers for name resolution.

Your router could be blocking the DNS traffic as well. Make sure that you are not filtering the DNS traffic on UDP port 53

Author

Commented:
My server can access the internet with the above config. My client machine will not connect to the domain or anything. Is there anything I need to enter under the Advanced tab pf the TCP/IP Properties sttings?
From the client, can you ping the router by IP?
server by IP?
server by name?
Anything out side of your network by name http://www.google.com? 
by IP 74.125.157.104?

Author

Commented:
On the client, I can ping all but the websites by name. I initially could not get on the internet with the above listed tcp/ip client config, but I went to the advanced tab under the properties of the client tcp/ip config for the network connection. Under the DNS tab I found only the server IP listed. I added the ip address for the default gateway and now I can get on the internet with the above client ip config. I just can't get on the domain or connect to the server using enterprise manager. This is frustrating to me to have all of you offer your help & expertise (& patience) and I can not solve this. Is there anything I can do in the client or server utilities of the server?
OK, so we have network connectivity to the Internet and your network from both server and client?

Can you map a drive to the server? \\servername\c$

Do you get any errors when you try to join the client to the domain?

Your server is hosting a domain and is not in a workgroup, correct?

Author

Commented:
When the client machine was connected to the server via crossover cable, the client would connect to the domain. Now thru the router, the client will not connect to the domain. I tried the above command and it came back with - "The system detected a possible attempt to compromise security. Please ensure tha
t you can contact the server that authenticated you".
Have you tried moving the client to a workgroup and then add it to the domain? Sometimes when there are changes like this you have to drop it, then re-add.

Author

Commented:
I tried this. Now i can't log back into the domain user account that had enterprise manager and everything else. I can only log into my family user account
You will have to log in as a local adminstrator, join it to the domain, reboot, and then your domain account should work. If you were logging in with the domain account and not connected to the domain, it was using cached credentials.

What operating systems are you user for client? server? I see 2003 server in the zone of this question, but I was simply checking. We have been looking all along at your network connectivity.
Hello All,

This still sounds like a DNS issue to me.
The reason that you can now get onto the internet is because by using your router's IP for DNS, your router will in turn query your ISP's DNS for Domain Name Resolution of Websites, private IP's are invisable to the internet so you will not be able to ping your server via your ISP. Only your Domain Controller's IP address is required which should be hosting its own DNS.

Can you please confirm that the DNS role is installed?
Can you also check that the DNS records for the Global Catalogue and the DC's DNS entry are correct?
Could you also check that the DNS record for your Client PC's is also correct?

just to sanity check, your server can access the internet with the IP config i supplied?

Please don't forget to answer jmiller's questions :)

Regards

Michael Ian Claridge
Server Infrastructure Engineer

Author

Commented:
The client is XP pro. The server has sql server 2000 & 2005. I can't reconnect to the domain. So I guess I'll have to connect the crossover cable back so the client & server are hookjed up like before. But Ihad some one set the initial connection up (I don't know much about the server software, obviously) so I don't know what the settings were for that hook up. Once I get that done I can reconnect to the domain so I can log back in to that user account (client machine) and then try this all over again thru the routher. I appologize for the frustration this must be creating.

Author

Commented:
After hours of further research and trial and error (and not having a great knowledge of server architecture) I was able to figure out that I was looking at the domain name wrong. Once I was able to use the correct domain name I was able to connect to the server, and thru enterprose manager to access the database on the client machine. So, in actuality, you both were correct. Setting up the static IP address and then using the correct domain name, access was granted. I appoligize for the frustration I created. But, again thank you for patience & expertise in solving this issue for me.
No frustration on my end, but lots of confusion. I am glad that you got it working properly.

I knew with info that MichaelIanClaridge was giving you that we had to be close to getting you connected, but something was missing. That is where not actually being in the same room or having connectivty to the device sometimes causes issues.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial