sql server udp port

The udp port  1045 on Windows 2003 for the sql server 2000 named instance stopped working. The default sql server is sql server 2005.   I installed portqry and the port 1045 is not listening on either tcp or udp.  I tried changing the port to 1435 and restarting the sql server.  Still not listening.  This has been working for over a year.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Can you help me?
Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
You need to click on "Request Attention" and get the zones for your question changed to include Server 2003 and Microsoft SQL servers, maybe also Microsoft Networking.
Raja Jegan RSQL Server DBA & Architect, EE Solution Guide
Awarded 2009
Distinguished Expert 2018

Commented:
>> The udp port  1045 on Windows 2003 for the sql server 2000 named instance stopped working.

Default UDP Port for SQL Server 2000 is 1434 and you can't change it out..
Kindly exclude UDP port 1434 in Windows firewall to get SQL Server working.
Raja Jegan RSQL Server DBA & Architect, EE Solution Guide
Awarded 2009
Distinguished Expert 2018

Commented:
To clarify more, SQL Server is developed to listen on one and only UDP port 1434 by default.

From BOL:
"SQL Server 2000 introduced support for multiple instances of SQL Server, SQL Server Resolution Protocol (SSRP) was developed to listen on UDP port 1434. This listener service responded to client requests with the names of the installed instances, and the ports or named pipes used by the instance."

"SQL Server Browser starts and claims UDP port 1434. SQL Server Browser reads the registry, identifies all instances of SQL Server on the computer, and notes the ports and named pipes that they use. When a server has two or more network cards, SQL Server Browser returns the first enabled port it encounters for SQL Server. SQL Server Browser support ipv6 and ipv4"

So would recommend this: If you have made any registry changes to set it to some other port, kindly reset it to 1434 and

Commented:
chreck if tcp\ip protocol is enabled fot sql server 2000 (check sql server network tool)
dear ,
if you have sql server 2005, i think that you can change the default port, all you need to check the below points.

1) TCP/IP Protocol for sql server is enabled or not. Sql Server COnfiguration Manager --> Sql Server Network Configuration --->Protocol for "Named Instance"
also check if the is any changes in the IP address, the new Ip address must also be enabled in the above link's
TCP/IP Properties Dailog.
2) if the Windows or any other Antiviur's Firewall has an exception added for the Said port or not.

Thanks
Most Valuable Expert 2014

Commented:
Note that some older apps (and their connectors) can't handle the redirection from the SQL Browser service. You have to go into the SQL Server Configuration Manager --> SQL Server 2005 Network Configuration --> Protocols for MyInstance --> TCP/IP --> IP Addresses tab and then either configure it there or at least get the port and configure it for the application.

Also disable Named Pipes -- nothing but trouble.
Today we applied SP 4 to our SQL Server 2000 and that resolved the problem.

Thank you for your help.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial