We help IT Professionals succeed at work.

OWA NET Framework version

masdf123
masdf123 used Ask the Experts™
on
Hi Guys,

I have noticed on Exchange 2007 SP2 and exchange 2010, both show NET Framework version: 2.0.50727.4927.

Shouldn't it be more recent maybe atleast 3.5?

2007 is running on Server 2003 r2 IIS6
2010 is running on Server 2008 r2 IIS7.5

Please guide.

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Depends on what it shipped with to be honest. If you're worried about the version you're running currently, you can always run automatic update and see if there's an option to update.
Top Expert 2010
Commented:
hi masdf

I havent been able to verify that with certainty that E2010 uses 2.0
I know that E2007 shipped with 2.0 and OWA probably uses the same thing. the error codes etc. when you are trying to fix OWA are related to .Net 2.0

I found a pre-req for E2010 which lists Windows 2008 server with .Net 3.5
http://technet.microsoft.com/en-us/library/bb691354.aspx

There is a possibility that OWA etc are using the .Net 2.0 version of the code, whereas the OS and other apps are using the .Net 3.5 or 4.0 version

End of the day .Net Framework is a Virtual Machine Stack which intercepts calls to the OS.
So 2.0 version will have XX functions
3.5 version will have XX + YY functions (backward compatible) etc.

I am not sure if I answered the question to your satisfaction. Please let me know if you have any doubts.

thanks

Author

Commented:
Hi,

I actually find this strange for Exchange 2010, but the web app shows 2.0

Thanks