Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

DCDiag /test:DNS failure

Avatar of rdivilbiss
rdivilbissFlag for United States of America asked on
Windows NetworkingWindows Server 2003Active Directory
8 Comments1 Solution7104 ViewsLast Modified:
I removed Active Directory, i.e. demoted the server from a DC to just another server.

I added 1 of my ISP's DNS Server to the local IP configuration so I would have Internet connectivity when I rebooted.  

Rebooted.

I Ran the AD Wizard establishing a new AD.
I Ran the DNS and DHCP configuration wizards, which in doing so I found the defaults to already be correct. e.g. In DNS there were already forward zone records for the server, there was an _msdcs,net.sb.local forward zone and a  _msdcs subforlder under the net.sb.local forward zone.

In DHCP, it already had the proper scope and reservations for 192.168.1.1 - 192.168.1.10. I did have to add the forwarders to DNS. The local IP dropped the DNS server of the ISP without my intervention and kept the server's IP address as the DNS server.

The router is 192.168.1.1 and the DC server (OLYMPUS) is 192.168.1.10.

I added my user id back to AD and it asked for my password, etc.

The clients pull (or are given) correct information:

Client
=======================================
C:\>ipconfig /all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : divilbiss
        Primary Dns Suffix  . . . . . . . : net.sb.local
        Node Type . . . . . . . . . . . . : Hybrid
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No
        DNS Suffix Search List. . . . . . : net.sb.local
                                            net.sb.local
                                            sb.local

Ethernet adapter Local Area Connection:

        Media State . . . . . . . . . . . : Media disconnected
        Description . . . . . . . . . . . : Broadcom 440x 10/100 Integrated Controller
        Physical Address. . . . . . . . . : 00-15-C5-1D-AD-82

Ethernet adapter Wireless Network Connection 3:

        Connection-specific DNS Suffix  . : net.sb.local
        Description . . . . . . . . . . . : Intel(R) PRO/Wireless 3945ABG Network Connection
        Physical Address. . . . . . . . . : 00-13-02-A0-78-97
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 192.168.1.136
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 192.168.1.1
        DHCP Server . . . . . . . . . . . : 192.168.1.10
        DNS Servers . . . . . . . . . . . : 192.168.1.10
        Lease Obtained. . . . . . . . . . : Saturday, July 03, 2010 3:00:43 PM
        Lease Expires . . . . . . . . . . : Sunday, July 11, 2010 3:00:43 PM

C:\>
=========================================================


SERVER
=========================================================
C:\>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : olympus
   Primary Dns Suffix  . . . . . . . : net.sb.local
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : net.sb.local

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : VIA Rhine II Compatible Fast Ethernet Adapter
   Physical Address. . . . . . . . . : 00-0B-6A-26-AC-F4
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : 192.168.1.10
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 127.0.0.1           <--Different from before but I think fine.

C:\>
=========================================================

Ran dcdiag /test:DNS

Got the attached: (Still errors)

Auth  Basc Forw Del     Dyn  RReg  Ext
PASS FAIL  PASS PASS PASS FAIL   n/a

Still do not understand
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Testing server: Default-First-Site-Name\OLYMPUS
      Starting test: Connectivity
         The host 5b763eb9-49aa-4924-af3b-d4b2dfc92347._msdcs.net.sb.local could
 not be resolved to an
         IP address.  Check the DNS server, DHCP, server name, etc
         Although the Guid DNS name
         (5b763eb9-49aa-4924-af3b-d4b2dfc92347._msdcs.net.sb.local) couldn't be
         resolved, the server name (olympus.net.sb.local) resolved to the IP
         address (192.168.1.10) and was pingable.  Check that the IP address is
         registered correctly with the DNS server.
         ......................... OLYMPUS failed test Connectivity
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++
C:\>DCdiag /test:dns

Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests

   Testing server: Default-First-Site-Name\OLYMPUS
      Starting test: Connectivity
         The host 5b763eb9-49aa-4924-af3b-d4b2dfc92347._msdcs.net.sb.local could
 not be resolved to an
         IP address.  Check the DNS server, DHCP, server name, etc
         Although the Guid DNS name
         (5b763eb9-49aa-4924-af3b-d4b2dfc92347._msdcs.net.sb.local) couldn't be
         resolved, the server name (olympus.net.sb.local) resolved to the IP
         address (192.168.1.10) and was pingable.  Check that the IP address is
         registered correctly with the DNS server.
         ......................... OLYMPUS failed test Connectivity

Doing primary tests

   Testing server: Default-First-Site-Name\OLYMPUS

DNS Tests are running and not hung. Please wait a few minutes...

   Running partition tests on : ForestDnsZones

   Running partition tests on : DomainDnsZones

   Running partition tests on : Schema

   Running partition tests on : Configuration

   Running partition tests on : net

   Running enterprise tests on : net.sb.local
      Starting test: DNS
         Test results for domain controllers:

            DC: olympus.net.sb.local
            Domain: net.sb.local


               TEST: Basic (Basc)
                  Error: No LDAP connectivity
                  Warning: adapter [00000001] VIA Rhine II Compatible Fast Ether
net Adapter has invalid DNS server: 127.0.0.1 (olympus.net.sb.local.)
                  Error: all DNS servers are invalid

            TEST: Records registration (RReg)
               Error: Record registrations cannot be found for all the network a
dapters

         Summary of test results for DNS servers used by the above domain contro
llers:

            DNS server: 192.168.1.10 (olympus.net.sb.local.)
               1 test failure on this DNS server
               Name resolution is not functional. _ldap._tcp.net.sb.local. faile
d on the DNS server 192.168.1.10

         Summary of DNS test results:

                                            Auth Basc Forw Del  Dyn  RReg Ext
               ________________________________________________________________
            Domain: net.sb.local
               olympus                      PASS FAIL PASS PASS PASS FAIL n/a

         ......................... net.sb.local failed test DNS

C:\>
ASKER CERTIFIED SOLUTION
Avatar of Psy053
Psy053Flag of Australia image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 8 Comments.
See Answers