Configure Public Folders Through Outlook

goraek
goraek used Ask the Experts™
on
Hello Xperts,

I'm trying to manage and configure permissons on public folders, but I don't seem to be able to get to it for some reason. I logged on as the administrator account, open Outlook and go into the Summary in the properties, everything's greyed out.

How do I change or modify the permissions? I read almost all the articles here, and the quick and easy solution is to use Outlook client to change/add/modify permissions.

Can someone please advise?

Cheers,
Goraek
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
You need to have owner permissions to the public folder you are wishing to change.
This can be set via Exchange manager in Exchange 2003 or Powershell in Exchange 2007.

Once you have owner rights, you will see the permissions tab in outlook - when viewing the folder properties.

Author

Commented:
Thanks for that.

Whats the command in Powershell to add this to the root directory?
Top Expert 2010

Commented:
Hi

Download PowerGui here
http://www.powergui.org/

Download the corresponding powerpack for your exchange version
http://www.powergui.org/kbcategory.jspa?categoryID=47

Fire-up PowerGui and go to public folders.
check properties permissions - do the needful.

PS: you have to be do this when you are logged in as domain admin
Bootstrap 4: Exploring New Features

Learn how to use and navigate the new features included in Bootstrap 4, the most popular HTML, CSS, and JavaScript framework for developing responsive, mobile-first websites.

Powershell command for 2007 - assuming folder under "All Public folders" is FolderName, and owner-to-be mailbox displayname is OwnerMailbox.

ONE FOLDER
add-PublicFolderClientPermission -identity "\FolderName" -user "OwnerMailbox" -accessRights Owner

ALL FOLDERS under FolderName
get-publicfolder -identity "\FolderName" -recurse | add-publicfolderclientpermission -accessrights "Owner" -user "OwnerMailbox"

Author

Commented:
I'm getting the following error trying to add administrative permission....      

Cannot bind parameter 'AccessRights'. Cannot convert value "publishereditor" to type "Microsoft.Exchange.Management.MapiTasks.PublicFolderAccessRight". Error: "Requested value 'publishereditor' was not found." (Add-PublicFolderClientPermission)      At line: 1      

What could this mean? What am I missing that I need to configure?

Cheers,
Goraek

Author

Commented:
I keep getting denied access:-

Add-PublicFolderClientPermission : Failed to commit the change on object "\" be
cause access is denied.

Anything I need to do with the Administrative side of things?

Author

Commented:
Thanks guys.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial