We help IT Professionals succeed at work.

RDP workstation within domain - server 2008

stefanomarco
stefanomarco used Ask the Experts™
on
hello - how do i go about RDP a workstation within my domain - I can RDP the server with port forwarding but I can't work out how I get to the workstation?
Server 2008
Window XP static IP
Netgear router static IP
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
You will have to change the port that the client listens on. So basically inside RDP Client you would do something like this:

WindowsXpMachine:3390

You can change the RDP Listening port in Windows XP here:

http://support.microsoft.com/kb/306759

Commented:
Or you can just RDP to the server, once you are in the server, RDP to the XP client...

no need to much around with anything then....

Narender GakkaAWS / DevOps / Cloud Consultant

Commented:
the best way would be to do it in the Netgear Router where you can connect the the Server on the default port 3389 and the client machine on port no 64444 (or any free port number).

Then configure the router to forward the 64444 to 3389 of the client IP address.

then you can connect to both client and the server using RDP from internet.

use rdp like this :

Server : IP Address
Client  : IP address:64444

Hope this helps...............Narender

Author

Commented:
thank you for your input
i've tried to setup exactly the same way I access the server via RDP ie custom service and then firewall rule - i've used port 64444 3390 - change the listening port on the client machine - which correct me if i'm wrong doesn't matter if you put the port number at the end of the ip address?
still not working :(
Narender GakkaAWS / DevOps / Cloud Consultant

Commented:
did you restart the client after doing the changes?????

Author

Commented:
yes - i did

Author

Commented:
here's a spanner - when I forward the RDP port on the router from the server to the client ie change 192.168.0.2 to 192.168.0.11 ... i still cant access the client machine

Commented:
You shouldnt have a problem. Just make sure that the PC you need to access has RDP setup with the appropriate user selected ( ie) the user that you are connecting from .

Hope this helps

Ed
First thing first. RDP to the server, and then try to RDP to the client. Can you connect? If I read your post correct, your unable to do it. Make sure that Remote connection is enabled on the client. Right click my computer > properties > remote settings  > Allow remote connections. Also, if your running a firewall, eiter disable it or allow exception for the port and service. You need to be able to connect internally before you connect externally. Once your able to connect to the client, you can then change the RDP listening port and then make sure you forward the port on the router to the client name or ip address if your using a static ip address. Once you have chosen your port, open RDP Client and the put in your WAN ip address followed by the port you assigned the client ex. 123.45.67.89:3390, you must have the trailing :3390 to connect or it will try logging into the server.

Author

Commented:
Thanks :)