Kaspersky Internet Security 2010 and Windows Remote Desktop (Windows 7)

pixalax
pixalax used Ask the Experts™
on
Hello All,
 It is really important for me to connect my desktop computer from my laptop. In this way, even tho I am at office, I can still access my other works / files in my desktop computer.
 I am using Windows 7. When I turn off Kaspersky 2010 Internet Security / Kaspersky 2010 Internet Security's firewall, I can access to my computer using remote desktop.
 If I am at the same network, I can access while Kaspersky is on, but I can not access if I am not in the same network (for example when I am at work, when I connect with 3G etc.)
 Thank you so much for your help in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Systems Administrator
Commented:
- Open the Kaspersky Settings
- Select Firewall
- Click the button Settings (next to the Enable firewall checkbox)
- Open the folder Packet rules on the Filtering rules tab
- locate Remote Desktop and edit it
- Select the Action Allow
- Confirm with OK, OK, OK

Then:

· Open Kaspersky

· Click on Settings.

· Click on Firewall on the left.

· Click on the Settings... button on the right.

· Click on the Networks tab.

You will usually see two connections here, one for the Internet , the other with the brand of network adapter you have (Intel, Broadcom, 3Com, etc). The Internet one should already be set to Public network, and the other set to Local.

· Right click on Local and select Trusted network.

· Click OK twice.


Did you make sure the windows one is disabled?

Author

Commented:
Thank you for your fast reply.

Author

Commented:
@Thethical:
 Yes, as I wrote before, when I disable Kaspersky, I have no problem to connect remotely.
I tried before what OfflineGeek wrote.
 I didn't see any remote desktop name under Packet Rules folder, so I added and allowed it but still it wasn't working.
 I restarted my computer, I saw what OfflineGeek wrote. I wanted to double check and this time I saw that it was blocked. I allowed Remote Desktop package and it worked perfectly.

 Thank you all for your time and concern.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial