We help IT Professionals succeed at work.

Cisco redundancy Trunks to router?

Eirejp
Eirejp used Ask the Experts™
on
Hi Everyone,

Need some advice.

I have two switches (3560s using only layer 2) and a 2811 router.

Between the two switches I have two x2 gigabit ethernet links running in a etherchannel.

I am also running two vlans. One for voice and one for data.

I want to run two trunks to the 2811. One trunk per switch to the router.

What is the best way to configure this on the router.

Usually if it was one trunk it would be two sub interfaces on that port with two IP address as gateways address.

I wanted to do this as a sort of backup redundancy type of thing but if I could get this working as a load balancing the two vlans (like s rapid spanning tree per vlan) that would be a plus as well.

Thanks in advance.


2010-07-06-00h16-06.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Les MooreSr. Systems Engineer
Top Expert 2008

Commented:
In my opinion, your best bet will be to simply use routed L3 links between each switch and two ports on the router, with EIGRP multi-link equal-cost automagic load balancing.
Advantage is load-balancing, redundancy instant failover (no spanning tree)

Example:
2811:
 int gig 0/0
   ip add 192.168.255.1 255.255.255.252
 int gig 0/1
   ip add 192.168.255.5 255.255.255.252
router eigrp 99
 network 192.168.255.0
 max-paths 2
ip cef

3560-1
 int gig 0/1
 no switch
 ip add 192.168.255.2 255.255.255.252
router eigrp 99
 network 192.168.255.0
 redistribute connected  <-- distributes local VLAN subnets to the router
 max-paths 2

3560-2
 int gig 0/1
 no switch
 ip add 192.168.255.6 255.255.255.252
router eigrp 99
 network 192.168.255.0
 redist connected
 max-paths 2

Author

Commented:
Thanks Lrmoore this is extremely helpful information. It worked straight away.

I need a bit of advice on setting up the gateway ip for the clients on each network.

from the router I can ping both switches but the switches cant ping the router addresses.

SWW01
interface Vlan10
 description << Voice Network >>
 ip address 172.16.10.10 255.255.255.0
!
interface Vlan20
 description << Data Network >>
 ip address 172.16.20.10 255.255.255.0


SW02
interface Vlan10
 description << Voice Network >>
 ip address 172.16.10.11.255.255.255.0
!
interface Vlan20
 description << Data Network >>
 ip address 172.16.20.11 255.255.255.0

I guess I would take away the vlans from the router and one of the switch ip address would be come my gateway?




interface FastEthernet0/0
 ip address 192.168.255.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.255.5 255.255.255.252
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description << Voice Network >>
 ip address 172.16.10.254 255.255.255.0
!
interface Vlan20
 description << Data Network >>
 ip address 172.16.20.254 255.255.255.0
!
router eigrp 99
 network 192.168.255.0
 auto-summary

Open in new window

Author

Commented:
Oh one more thing. I was going to use the 2811 to register the cisco phones.
Sr. Systems Engineer
Top Expert 2008
Commented:
I would use HSRP on the VLAN interfaces of the switches. Use the HSRP virtual IP as the default gateway for the VLAN hosts. Use MHSRP to create multiple HSRP instances and set half the users to point to one Virtual IP and half to the other to achieve some load-sharing.

I would remove the VLAN data/interfaces from the 2811 router

>I was going to use the 2811 to register the cisco phones.
Create a loopback interface on the router and use the loopback IP for option 150 IP address and in telephony-services.

Set both switches' default route to point to the 2811 (use connected L3 interface)
 ip route 0.0.0.0 0.0.0.0 192.168.255.x

Author

Commented:
Thanks Lrmoore! this is great!

HSRP/MHSRP is the way to go then.

Looks like the Cisco Packet Tracer 5.3 does not support HSRP on their virtual 3560's so I cant really test the setup but everything up to this point has worked perfectly. Big Thanks!

Author

Commented:
I am thinking it would look something like this then

Router:
--------------------------------------------
interface Loopback0
 description << Loopback for Voice Services >>
 ip address 192.168.255.254 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.255.1 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.255.5 255.255.255.252
 duplex auto
 speed auto
!
router eigrp 99
 network 192.168.255.0
 auto-summary
--------------------------------------------

SW01
--------------------------------------------
interface FastEthernet0/23
 switchport access vlan 20
 switchport mode access
 switchport voice vlan 10
 spanning-tree portfast
!
interface FastEthernet0/24
 no switchport
 ip address 192.168.255.2 255.255.255.252
 standy 1 ip 192.168.
!
interface GigabitEthernet0/1
 description << Etherchannel to SWCORE02 >>
 channel-group 1 mode active
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 description << Etherchannel to SWCORE02 >>
 channel-group 1 mode active
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description << Voice Network >>
 ip address 172.16.10.253 255.255.255.0
 standby 1 ip 172.16.10.254
 standby 1 piority 110
 standby 1 preempt
 !
interface Vlan20
 description << Data Network >>
 ip address 172.16.20.253 255.255.255.0
 standby 1 ip 172.16.20.254
 standby 1 piority 110
 standby 1 preempt
 !
router eigrp 99
 redistribute connected
 network 192.168.255.0
 auto-summary
 
 ip route 0.0.0.0 0.0.0.0 192.168.255.5 1
 ip route 0.0.0.0 0.0.0.0 192.168.255.1 2

--------------------------------------------

SW02
--------------------------------------------
router eigrp 99
 redistribute connected
 network 192.168.255.0
 auto-summary

interface FastEthernet0/24
 no switchport
 ip address 192.168.255.6 255.255.255.252
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 description << Etherchannel to SWCORE02 >>
 channel-group 1 mode active
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
 description << Etherchannel to SWCORE02 >>
 channel-group 1 mode active
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Port-channel 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!

 interface Vlan10
 description << Voice Network >>
 ip add 172.16.10.252 255.255.255.0
 standby 1 ip 172.16.10.254
 
!
interface Vlan20
 description << Data Network >>
 ip add 172.16.20.252 255.255.255.0
 standby 1 ip 172.16.20.254
 
 ip route 0.0.0.0 0.0.0.0 192.168.255.5 1
 ip route 0.0.0.0 0.0.0.0 192.168.255.1 2


What do you think? If I would appreciate your input.

Thanks! Carl

Commented:
If Packet tracert is giving you a hard time with the config you may want to look at GNS3, to emulate a real IOS, however this support only routers no swithes because of the ASIC completixy, still you could ass a Switch module to the router and get some switching configs done.
Les MooreSr. Systems Engineer
Top Expert 2008

Commented:
Should work just fine.