Terminal Server 2008 printer redirection failure

SimonGreenbank
SimonGreenbank used Ask the Experts™
on
Please help! I have a Windows Server 2008 terminal server, with printer redirection working perfectly for the last year for 10 users. The printer redirection has stopped working for all users. Have checked (and rechecked) the following ...
- RDP client has Printer checked under Local Resources tab
- Terminal Services Configuration/RDP-Tcp connection/Client Settings tab Windows Printer unchecked (not disabled)
- Group Policy on the SBS 2003 domain controller (Computer Configuration/Admin Templates/Windows Comp/Terminal Services/ClientServer data redirection) - all items Not configured
- Local Group Policy on the terminal server (Computer Configuration/Admin Templates/Windows Components/Terminal Services/Terminal Server/Printer Redirection) - all items not configured
- Event logs (system & application) not indicating any problems
The problem may have been triggered by installation then removal of vSpace software for NComputing L230 thin client.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
I ahve seen 2 things cause this in the past
1- an RDP client update
2- in the RDP client uncheck "ports & Smart cards"

Author

Commented:
Hey thanks for your comment. Just tried unchecking ports & smart cards - no change unfortunately. In this case we haven't changed RDP client.

Commented:
Try Royal TS on one of the clients to narrow down where the issue is (client or server)
http://www.code4ward.net/main/
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
Just tried Royal TS. Still no printer redirect. I guess it's the server.

Author

Commented:
Interesting to note that redirect of disk drives won't work either. (Checked relevant settings under Advanced tab in client settings).
Commented:
yeah the only time I have seen that is when the ports where checked and that was a complete anomaly in itself.

Check if this was turned off
printer redirection on the server

Go into Administrative tools -> Terminal Service Configuration -> Right
click on "RDP-TCP" and check in there.

Check out these links
http://vspug.com/rhouberg/2008/02/11/windows-server-2003-update-breaks-rdp/

http://blogs.technet.com/b/askperf/archive/2007/08/24/terminal-server-and-printer-redirection.aspx
I would try deleting the RDP-tcp listener and recreating it. See if that fixes it.

Cláudio Rodrigues
Microsoft MVP - RDS
Citrix CTP

Author

Commented:
Thanks so much for your assistance guys! IT's fixed!! Tried deletion/recreation of RDP-Tcp link, however the thing that got it working again was the registry change detailed below. I read through the page "http://blogs.technet.com/b/askperf/archive/2007/08/24/terminal-server-and-printer-redirection.aspx" as per recommendation.

Changed the registry as follows:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\Wds\rdpwd
Changed fEnablePrintRDR value from 0 to 1

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial