Undo mount install - Linux (Ubuntu)

SullX
SullX used Ask the Experts™
on
Hello! I followed the directions located here ( http://www.arsgeek.com/2006/09/25/ubuntu-tricks-how-to-mount-your-windows-partition-and-make-it-readwritable/ ) to the tee and it worked just fine.. the only thing is that i accidentally mounted the wrong partition (I needed to mount sda2 and i mounted sda1).

I have tried uninstalling all of the packages it had me install and start over (even usinjg differen groups and folder names etc) but every time I try to redo what the instructions say for the correct partition I get a mount error on boot up.

Could someone please give me the set of commands that will completly undo everything the above tutorial does, so I can start from scratch?

Thank you very much
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
If you could post two things:

1. The error message you're getting at boot
2. The contents of your fstab file (/etc/fstab)

OK, three things...
3. Where you are right now. Did you remove any of the items you installed or the user/groups you created?

Commented:
Theoretically only thing you have to alter is /etc/fstab

If you follow the instructions completely and use the wrong one you managed to get work does it still work?
If it does do
gksudo gedit /etc/fstab
and alter it to point to correct partition. Does it work after that?

Author

Commented:
tniemetz:

1. An error occured while mounting /media/windows Press S to skip mounting or M for manual recovery.
2. I have deleted the added contents but here it is:
---
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/host/ubuntu/disks/root.disk /               ext4    loop,errors=remount-ro 0       1
/host/ubuntu/disks/swap.disk none            swap    loop,sw         0       0
---

3. The only other thing that is deleted is the group it had me add.

Aarop:

Nope. Tried.



So I think i know why I am having this issue. I installed ubuntu using WUBI the windows installer. I don't believe it actually created another partition, but rather it is installed in the windows C. Ubuntu still sees two partitions though:

---

root@ubuntu:/media# fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x8da73bfe

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      102400    7  HPFS/NTFS
Partition 1 does not end on cylinder boundary.
/dev/sda2              13       38914   312466432    7  HPFS/NTFS
Partition 2 does not end on cylinder boundary.

---

Thoughts? I need access to the windows portion of this partition.

Author

Commented:
... \host ...
Commented:
I figured it out. Because I installed with WUBI the windows C:\ is /host in Ubuntu 10.04. Thanks.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial