GPINVENTORY.exe Throwing Error : "Could not Connect"

vourneenward
vourneenward used Ask the Experts™
on
Hi,

I am looking to collect information on Local Group Policy, I have run GPINVENTORY on about 300 servers and extraxted the information I need sucessfully.

On  the remaining 100 servers, GPINVENTORY fails throwing bcak the following "Error, could not connect"

The firewall service is disabled on all of these servers and I am running the GPINVENTORY.EXE with full Domain Admin rights.

Can anyone make any suggestions as to what is going wrong?

Thank You!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Have you checked to see if the Server service is running on those 100 machines. If it is not try starting it and see if GPINVENTORY will work then.

Author

Commented:
Thanks,

The server service is running on all these servers. This does not appear to be the problem,

Cheers!
On a couple of the problem servers, run WBEMTEST and confirm their WMI setup is running as required.

Commented:
Another thing to check would be the Windows Firewall. If you have it installed on any of those machines try to disable it and see if it will work then.

Author

Commented:
there is NO Windows Firewall enabled on these servers. Thanks!

Commented:
Do you have File and Printer Sharing enabled on the NIC for those systems?

Author

Commented:
Yes File and print is enabled on the NIC, Thanks

Author

Commented:
MidnightOne: - how would you suggest I use WBEMTEST?

thanks!

Author

Commented:
anymore suggestions, help, this is becoming urgent.
open WBEMTEST
Click on connect
In the top box, enter \\SERVER\root\cimv2 and click connect
Click on connect, then the recursive radio button, then OK

What are the results?

Author

Commented:
unfortunately I cannot see any recursive button .... see attached,
any help would be great...
Untitled.jpg
Sorry, skipped a lot of steps there, didn't I? :-|

In the Namespace box, enter \\SERVER\root\cimv2 and click Connect. Then the Enum classes (and all other buttons) should be clickable.

Click Enum Classes, then the recursive radio button, then OK.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial