Vista PC can't explore another computer on home network

PC_User321
PC_User321 used Ask the Experts™
on
A Vista PC used to be able to print on the printer connected to another computer (called 250gig, running XP), but now it can't find the printer.  Perhaps it was caused by an automatic Windows update.
Another Vista computer can still print on the XP's printer, so I know the fault is not on the XP.

The Vista computer used to be able to explore 250gig's shared files, but now when I try to "explore" 250gig I get the message "\\250gig is not accessible. You may not have permission to use this network resource. .... The Server service is not started".
I found that the Server service _was_ running, but for good measure I stopped it and started it again -- no difference.

The settings in Control Panel \ Network and Sharing Center are:
   Network discovery -- On
   File sharing -- On
   Public folder sharing -- On
   Printer sharing -- On
   Password protected sharing -- On
   Media sharing -- Off

The user is an Administrator.

I would be grateful for any help.  Thanks.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
An XP update disables sharing at the firewall. Make sure Windows Firewall is set to allow the connection.

Author

Commented:
Thanks.
I turned off Windows firewall on the XP and the Vista machines but the situation was unchanged.
The XP machine also has Comodo firewall but I could not find a way of stopping it.  But the other Vista machine can read the XP's shared files so presumably there is no blocking being done on the XP machine.

Author

Commented:
"ping 250gig" works correctly
Commented:
Cna you please try the below:

1.Click Start, click Run, type “regedit”, and then click OK.
2.Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
3.Click Edit, point to New, and then click DWORD Value.
4.Type “IRPStackSize”, and then press ENTER to name the value. (Note Type IRPStackSize exactly as it is displayed. This is case sensitive.)
5.Click Edit, and then click Modify.
6.In the Data Value box, type 30 or any value max of 50, and then click OK. (make sure it's decimal not hex)
7.Restart the machine

also make sure your firewall or AV software on VISTA is not blocking any traffics

Commented:
Or you can try the following as well as it may be permission issues:

Add the user as the owner for the XP machines hard disks. properties of EACH hard disc (from "My Computer") and under Sharing, add the user with full access permissions WITH subfolders, etc. selected. Then go tothe Security Tab, the Advanced... button and make the user the OWNER of the disk, again WITH subfolders, etc. This can take some time..
Also for the printer give the user FULL ownership

Author

Commented:
Thanks for your suggestions, mjabim1.
I got it working somehow.  I tried many things - here is a summary of the things that are probably relevant:
  o  Restarted the Vista computer - no good
  o  Added a guest user - no good
  o  Added IRPStackSize as you suggested and restarted computer - good
  o  Disabled the guest user then restarted - still good
  o  Removed IRPStackSize then restarted - still good

So in effect I did nothing, but it stayed working!  Very strange.

Author

Commented:
Thanks mjabim1

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial