We help IT Professionals succeed at work.

Etherchannel with VMware ESX 4 and Dell m1000e and Cisco 3130G switchblades

fluce
fluce used Ask the Experts™
on
We are in the process of setting up a Dell M1000e enclosure filled with Dell M710 blades and (4) Cisco 3130 switches. The Cisco 3130's will be connected to Cisco 4510R-E switches which are our core switches.

A couple of us have taken a crack at the Cisco setups but have not got it quite right.

The desire is to have four ports on the 4510R-E switch (G3/35 - 38) trunked to four ports on each of the two switch blades (G1/0/17 - 20) assigned to the Network (VLAN10), Console (VLAN50), and VMotion (VLAN60), as an EtherChannel. From there to have the ESX servers connect to the 3130G on ports G1/0/1 and G1/0/9 which are the two ports that are assigned to the 3130G switch as an example. The appropriate parts of the Cisco 4500 and Cisco 3130G are listed.

Any help in correcting this configuration is appreciated.
Cisco 4500:

interface Port-Channel10
switchport
switchport trunk allowed vlan 10,50,60
!
interface GigabitEthernet3/35
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,50,60
channel-group 10 mode active
!
interface GigabitEthernet3/36
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,50,60
channel-group 10 mode active
!
interface GigabitEthernet3/37
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,50,60
channel-group 10 mode active
!
interface GigabitEthernet3/38
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,50,60
channel-group 10 mode active
!
interface vlan10
 ip address 192.168.1.254 255.255.255.0
interface vlan 50
 ip address 192.168.5.1 255.255.255.0
interface vlan 60
 ip address 192.168.6.1 255.255.255.0


Cisco 3130:
interface Port-Channel10
switchport
switchport trunk allowed vlan 10,50,60
!
interface GigabitEthernet1/0/1
 switchport mode trunk
 switchport trunk allowed vlan 10,50,60
!
interface GigabitEthernet1/0/9
 switchport mode trunk
 switchport trunk allowed vlan 10,50,60
!
interface GigabitEthernet1/0/17
 switchport mode trunk
channel-group 10 mode desirable
!
interface GigabitEthernet1/0/18
switchport mode trunk
channel-group 10 mode desirable
!
interface GigabitEthernet1/0/19
 switchport mode trunk
channel-group 10 mode desirable
!
interface GigabitEthernet1/0/20
switchport mode trunk
channel-group 10 mode active

Open in new window

Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Paul SolovyovskySenior IT Advisor
Top Expert 2008

Commented:
What exactly are you having an issue with?  

Is the issue the connection between the 3130 and 4500 or ESX hosts and the 3130 switches?

How many total ports do you have on the ESX host?  Keep in mind that you should have multiple vswitches so that your ip stack is separated per vswitch and that with iscsi unless you use MPIO (multipathing) you will not be able to get more than 1GB of bandwith to your SAN since the transmission of data is per sesssion.

Author

Commented:
The trunked vlans work great. Able to operate right through from the core switch back down to the ESX server. However the set up of the Etherchannel is causing the grief. We end up with a up/down (suspended).

Each of four 3130G switches has four physcial ports.  So the thought was to follow Dell's best practices and use 2 sets of the four ports (each four port set to be agregated together) for the iSCSI SAN and the rest to be setup to carry the console/vmotion/normal network traffic (also agreggated into sets of four).

Each of the ESX boxes has 2 ports assigned per switch and look to be either setup as normal Eithernet or iSCSI.

We continue our struggle to get things to trunk however.
Commented:
Turns out that once we sat down and looked at everything we needed to walk through it one step at a time. Create the trunk, then the Etherchannel. Seems we were having issues keeping the trunked vlans the same before attempting to create the Etherchannel. It works now!

Author

Commented:
We solved this one ourselves as we apparently had too many admins looking at the same thing.