Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Problem deploying VSTO addin in 64 bit Windows Terminal Server environment

Avatar of timetracer
timetracer asked on
Windows Server 2003Microsoft Server OSMicrosoft Development
5 Comments1 Solution1883 ViewsLast Modified:
Hi,

We are having a problem deploying a VSTO 2005 Second Edition Add-In and would appreciate any help with this.

We previously successfully deployed this add-in onto a 32bit Windows 2003 terminal service environment. By default VSTO installs on a per-user basis. But we got around this limitation by creating a custom CASPOL script which we ran after installation. This script removes the per user permissions and replaces them with per machine permissions.

I have included an example of this script below.

The client has now moved to a 64bit terminal services environment and our add-in is no longer working. The add-in is available but will not load, so our suspicions are that the problem is with the CASPOL script that it is no longer working.

We have tried editing our script so that it targets the Framework64 folder instead of Framework etc. without success.

Example script

%windir%\Microsoft.NET\Framework\v2.0.50727\caspol.exe -u -q -rg "OurDll.a5376b32-bs02-4f7f-897e-025bd33c0fb8"

%windir%\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -q -rg "OurDll.a5374b32-bf02-4f7f-897e-025re33c0fb8"

%windir%\Microsoft.NET\Framework\v2.0.50727\caspol.exe -m -q -ag My_Computer_Zone -url "OurUrl\*" Nothing -n " OurDll..a5374b32-bblas-4f7f-897e-025bd33c0fb8" -d "Code Group for Our App"

....etc...
 
I'd appreciate whatever help anyone can offer.

 Thanks,

Peter Evans
ASKER CERTIFIED SOLUTION
Avatar of Cláudio Rodrigues
Cláudio RodriguesFlag of Canada imageFounder and CEO

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 5 Comments.
See Answers