BES - the setup application cannot find the required mapi libraries

ChillSmith
ChillSmith used Ask the Experts™
on
Hi,

I am installing BES Express on Windows Server 2003 and I get the following error:

"the setup application cannot find the required mapi libraries"

We currently have Exchange Server 2007.
Any suggestions?


Thanks,


Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
http://docs.blackberry.com/en/admin/deliverables/7307/Release_Notes.pdf


This has a number of errors and fixes. You may want to check here and see if the error is there. I did not see the exact phrasing, but you may have seen another error that is on here. The type of OS is important with some of the errors. Is it 32 or 64 bit install?

Author

Commented:
This is an x86 install.

Checking doc now.

Author

Commented:
Doesn't seem to cover this exact issue but does cover similar issues on Windows Server 2003 x64

Commented:
That is what I saw and the reason I asked. It may not hurt to try that. Registering the DLL would not mess up anything.

Author

Commented:
What DLL are you talking about?

Commented:
If you install the BlackBerry Enterprise Server on Windows Server 2003 64-bit, in certain circumstances, the setup application cannot find the CDO library.
Workaround
1.In a command prompt, navigate to C:\Program Files (x86)\ExchangeMapi.
2.Run regsvr32 cdo.dll.

Author

Commented:
The document refers to the folder:
C:\Program Files (x86)\ExchangeMapi.

I have searched for C:\program files\ExchangeMapi (considering I have a x86 server)

The folder "ExchangeMapi" is not there.
I've also searched the Hard drive for "cdo.dll" with no success?

Author

Commented:
Thankyou for your help!

That did it.


Thanks for this all. This helped me get BES Express installed at home.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial