Unable to connect to shared printer at XP computer (some kind of permission problem)

Martin_Radbo
Martin_Radbo used Ask the Experts™
on
One single 2003 server SBS, with AD. A couple of XP Pro computers, all of them joined to the domain.

Sharing a printer from server works fine (permission are set correctly yes) but we have one locally installed printer at a PC (LPT1) and I can share it, set permissions to everyone = full access, it shows up in the AD catalog.

But then adding a new printer from another PC (or from the server, does not matter) I get a popup box asking me for credentials. Same thing happen then sharing a folder from that PC.

There must be something "basic" with this PC I miss.

Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Did you add the permissions for everyone in the domain or for everyone from the PC (Name)?

It sounds like the computer account may be out of synch with the domain.  Check the local system log of that PC and the Domain Controllers in the same Site as the PC.  IF you see netlogon errors related to the PC try rejoining it to the domain or using the netdom utility to reset the computer account.

Author

Commented:
Permissions are set correctly (domain users, e.t.c.) but I think ranmasao12 are having a good idéa. I will try as soon as possible.
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
Yesterday I tried to leave and join the domain but that made no difference. Do you have other ideas?
So to clarify the only time you get prompted is when you attempt to access the printerthat is shared from a PC?  
When you provide normal user credentials does it work?  if not can you provide elevated credentials (like a Domain Admin) and have it work?
Do the event logs on the system sharing the printer (especially the security log) show anything that might be helpful?
Can you create a share on the same system sharing the printer and access the share?

Problem solved. Then trying to connect from server I got a meaningfull error message so I did not have to guess...
;-)

Reason for the problem was that client PC was not clock synced with server. "net time //servername /set /yes"   was the thing.

Thanks for your suggestions anyway

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial