We help IT Professionals succeed at work.

Check Early Media configuration

sparticus1701
sparticus1701 used Ask the Experts™
on
I am using AsteriskNOW 1.5 with Asterisk 1.6. People are calling in and not getting the ringing sound before we pick up the phone. The guys at Bandwidth.com say we need to check the Early Media configuration. How do I do that?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Most Valuable Expert 2012

Commented:
Early media is a SIP 183.  It usually happens when some ISDN links send empty media frames before the call is in ringing or progress state. The SIP channel will then send 183 indicating early media which will be empty - thus users get no ring signal.

In sip.conf in the general section, set prematuremedia=no. Default is "yes".

Setting this to "no" will stop any media before we have call progress.

Author

Commented:
I added that command and restarted Asterisk, but there is still no ringing.  This is what Bandwidth.com says:

============================
Based on the below messaging, I am seeing 16 seconds of 183 with SDP before receiving a 180 with no SDP. Can you confirm Early Media is properly configured on your Asterisk 1.6 PBX?

Mon Jun 28 22:56:50 2010 64.146.xxx.xxx:5060 ---> 216.82.224.202:5060

SIP/2.0 183 Session Progress
Via: SIP/2.0/UDP 216.82.224.202;branch=z9hG4bKacd1.13820505.0;received=216.82.224.202
Via: SIP/2.0/UDP 67.231.8.93;branch=z9hG4bKacd1.d202da93.0
Via: SIP/2.0/UDP 4.68.250.148:5060;branch=z9hG4bK506071629460-1256984240471
Record-Route:<sip:216.82.224.202;lr;ftag=VPSF506071629460>
Record-Route:<sip:67.231.8.93;lr=on;ftag=VPSF506071629460>
From:"PT ANGELES WA"<sip:+1360460xxxx@4.68.250.148>;tag=VPSF506071629460
To:<sip:+1360681xxxx@67.231.8.93:5060>;tag=as61e769ca
Call-ID: SEAMGC0120100628225650015576@209.244.63.11
CSeq: 1 INVITE
Server: Asterisk PBX 1.6.2.8
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Contact:<sip:+136068xxxxx@64.146.xxx.xxx>
Content-Type: application/sdp
Content-Length: 261

v=0
o=root 1864940 1864940 IN IP4 64.146.xxx.xxx
s=Asterisk PBX 1.6.2.8
c=IN IP4 64.146.xxx.xxx
t=0 0
m=audio 36004 RTP/AVP 0 101
a=rtpmap:0 PCMU/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv
--
Mon Jun 28 22:57:06 2010 64.146.xxx.xxx:5060 ---> 216.82.224.202:5060

SIP/2.0 180 Ringing
Via: SIP/2.0/UDP 216.82.224.202;branch=z9hG4bKacd1.13820505.0;received=216.82.224.202
Via: SIP/2.0/UDP 67.231.8.93;branch=z9hG4bKacd1.d202da93.0
Via: SIP/2.0/UDP 4.68.250.148:5060;branch=z9hG4bK506071629460-1256984240471
Record-Route:<sip:216.82.224.202;lr;ftag=VPSF506071629460>
Record-Route:<sip:67.231.8.93;lr=on;ftag=VPSF506071629460>
From:"PT ANGELES WA"<sip:+1360460xxxx@4.68.250.148>;tag=VPSF506071629460
To:<sip:+1360681xxxx@67.231.8.93:5060>;tag=as61e769ca
Call-ID: SEAMGC0120100628225650015576@209.244.63.11
CSeq: 1 INVITE
Server: Asterisk PBX 1.6.2.8
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Contact:<sip:+1360681xxxx@64.146.xxx.xxx>
Content-Length: 0
============================

I also noticed a progressinband field in Asterisk documentation, which seems to relate to ringing signals.  It defaults to 'never', and it is not currently present in my sip.conf (sip_general_custom.conf).  Should it be there?

Commented:
progressinband is the parameter you need to be using for this problem. You can add it to sip_general_custom, but then it will apply to all sip peers so it would be preferable to add it only to the bandwidth.com trunk definition. You should be able to add it in the boxes where you define the Outgoing PEER details and the Incoming USER details (try adding it to the Incoming USER details first - if that makes no difference, add it to both Incoming and Outgoing details).

I suggest you try setting it to yes first. That should fix the problem. It is possible that a setting of no will also work. The default setting of never is certainly not going to help you.

Author

Commented:
I just tried every combination of the two settings prematuremedia and progressinband, and restarted Asterisk between each one.  At least on the Verizon phone I tried, none of the combinations worked.

I currently have the settings to prematuremedia=no and progressinband=yes.

I used sip_general_custom since the Bandwidth.com trunks are the only trunks we have.

Commented:
In that case, please set the "sip_general_custom.conf" file back to the way it was in the first place and try the following instead:

On the GUI form for the Inbound Route, check the box for "Signal RINGING" which is located in the Options section. See if that makes a difference.
I found the solution:  The ring group's MOH was set to 'default' instead of 'Ring'.  Thanks for your help.

Author

Commented:
Moderator,

I found the solution to the problem but I would like to award 60 points each to the two responders.  I'm not sure if or how I can do that.  Thanks!