Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

SBS 2008 SSL conflict with Default website and SBS Web Applications

Avatar of kpturner
kpturner asked on
Microsoft IIS Web ServerSBSWindows Server 2008
21 Comments1 Solution5099 ViewsLast Modified:
We have just migrated from SBS 2003 to SBS 2008. The migration finally completed last week.  Most of the important things are working fine, but there are some niggly issues which are puzzling me, almost all to do with IIS and remote access.

Once the migration had completed, both "Default web site" and "SBS Web Applications" were bound to port 443 for SSL.  This meant that one of the servers ("SBS Web Application" would not start).  Although it would not start, it was not too bad because our mobile devices (mainly iPhones) were able to use activesynch/direct push presumably via the Microsoft-Server-ActiveSynch virtual directory within "Default Web SIte".  We could also get OWA via https://remote.domain/owa.

However, since SBS Web Applications could not start we cannot get to anything else like RWW etc.

When I investigated this I found various resources (including some posts on here)  telling me that "Default Web site" should only be bound to port 80, not 443.  Sure enough, if I remove the 443 binding I can then start "SBS Web Applications".  However, that instantly means I lose activeSynch/Direct Push for our remote devices and I can no longer access OWA.

It seems like a catch-22 unless there is something missing in SBS Web Applications that should replicate the activesynch and OWA functions in Default Web Site.  I know for a fact that there was an OWA virtual directory within SBS Web Applications that is no longer there. I found some script that should recreate it:

New-OWAVirtualDirectory -WebsiteName "SBS Web Applications" -OwaVersion "Exchange2007" -ExternalAuthenticationMethods Fba
but when I run that I get the following error:
New-OwaVirtualDirectory : An error occurred while creating the IIS virtual dire
ctory 'IIS://CHROMIS.CoralTree.local/W3SVC/3/ROOT/owa' on 'CHROMIS'.
At line:1 char:24

Even if we got OWA working I am still unsure how activesynch can work.  We tried uninstalling/installing ClientAccess to no avail and ran the "Fix my network" wizard - which didn't find anything to fix.

I am stumped.
ASKER CERTIFIED SOLUTION
Avatar of kpturner
kpturner

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 21 Comments.
See Answers