Can't open company website from inside our LAN

bobox00
bobox00 used Ask the Experts™
on
The IP address of our website has just recently changed and I have updated the new address with our website's name server. I can open the website outside of our office LAN without any issues, but inside our office LAN, I get an error page. How may I resolve this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Do you run DNS inside your LAN? If so make sure that the DNS entry is correct for your website, or if it's not there at all you can add it.

Author

Commented:
The DNS had the former IP address in form of an A record. I edited the A record and put-in the new IP address. While saving though, I did notice an error message that said "the associated ptr record cannot be created"

Author

Commented:
How do I properly create the DNS record?
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

First I'd just try deleting the record from the DNS we can recreat it later if need-be. Once it's deleted go to a computer then use the command:

ipconfig /flushdns

then try and go to your website.

I do have one question though, are you running the webserver from inside your network and wish to use an intranet IP address to connect to it?

Commented:
Check your firewall settings and your Active Directory. If you have NAT setup on the firewall and and a DCHP server that maybe the problem.
Had a similar issues with a client. All computers were outside the DMZ except for the web server. The local DHCP server was setup for 172.x.x.x. and the firewall was using 192.x.x.x  addresses.

Author

Commented:
I am not running the webserver internally.

Author

Commented:
My firewall does address translations and is also configured as the DHCP server for my LAN.
Did you delete the DNS entry and flush the DNS on a workstation?

Author

Commented:
Yes. I got an error page.

Commented:
Can you tell us what the error message says? Is it a 404 page not found?
Have you contacted you web host to check the DNS records there?

Author

Commented:
For internet explorer, the error page says
"Under Construction


The site you are trying to view does not currently have a default page. It may be in the process of being upgraded and configured.

Please try this site again later. If you still experience the problem, try contacting the Web site administrator.


--------------------------------------------------------------------------------

If you are the Web site administrator and feel you have received this message in error, please see "Enabling and Disabling Dynamic Content" in IIS Help.

To access IIS Help
Click Start, and then click Run.
In the Open text box, type inetmgr. IIS Manager appears.
From the Help menu, click Help Topics.
Click Internet Information Services."

For Firefox,
"Server not found

Firefox can't find the server at www.bluecanyonpartners.com.


    *   Check the address for typing errors such as
          ww.example.com instead of
          www.example.com

    *   If you are unable to load any pages, check your computer's network
          connection.

    *   If your computer or network is protected by a firewall or proxy, make sure
          that Firefox is permitted to access the Web."

However, I can open the website using an AT&T wireless internet device on my laptop, after disconnecting the laptop from my LAN. The website is www.bluecanyonpartners.com

Commented:
Are you running and IIS server on a Windows server at your location? for OWA?

Author

Commented:
Ron how do I verify this? We no longer host our exchange server in-house, but exchange has not been completely removed or shut down.

Author

Commented:
Ron, yes we are. Please let me know how this may help resolve the problem.

Author

Commented:
Here's a traceroute done on a client machine on our LAN:
C:\Windows\system32>tracert 192.150.2.140

Tracing route to nj.worldsecuresystems.com [192.150.2.140]
over a maximum of 30 hops:

  1    <1 ms    <1 ms    <1 ms  192.168.5.61
  2     1 ms    <1 ms     1 ms  65.199.111.105
  3     9 ms     8 ms     8 ms  248.ATM1-0.GW3.CHI6.ALTER.NET [152.179.5.57]
  4     8 ms     8 ms     8 ms  0.ge-3-0-1.XL3.CHI6.ALTER.NET [152.63.66.14]
  5     9 ms    16 ms     9 ms  0.ge-5-2-0.XL3.CHI13.ALTER.NET [152.63.64.217]
  6     9 ms     9 ms     9 ms  0.ae3.BR3.CHI13.ALTER.NET [152.63.66.74]
  7     9 ms     9 ms     9 ms  204.255.168.70
  8    10 ms    10 ms    10 ms  ae-1.r20.chcgil09.us.bb.gin.ntt.net [129.250.4.112]
  9    39 ms    32 ms    32 ms  as-1.r21.nycmny01.us.bb.gin.ntt.net [129.250.6.14]
 10    38 ms    31 ms    38 ms  po-3.r01.nycmny01.us.bb.gin.ntt.net [129.250.2.51]
 11    33 ms    40 ms    40 ms  xe-4-3.r01.nycmny01.us.ce.gin.ntt.net [129.250.193.126]
 12     *        *        *     Request timed out.
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15     *        *        *     Request timed out.
 16     *        *        *     Request timed out.
 17     *        *        *     Request timed out.
 18     *        *        *     Request timed out.
 19     *        *        *     Request timed out.
 20     *        *        *     Request timed out.
 21     *        *        *     Request timed out.
 22     *        *        *     Request timed out.
 23     *        *        *     Request timed out.
 24     *        *        *     Request timed out.
 25     *        *        *     Request timed out.
 26     *        *        *     Request timed out.
 27     *        *        *     Request timed out.
 28     *        *        *     Request timed out.
 29     *        *        *     Request timed out.
 30     *        *        *     Request timed out.

Trace complete.

C:\Windows\system32>

Open in new window

Author

Commented:
I still cannot open my our company website from inside our office LAN. Our ISP has checked and found nothing. I also checked my firewall and found nothing.

Commented:
Is your website hosted on the same machine as the DHCP server that controls your internet access?

Commented:
Sorry, had to to a little research on your domain name.
So you used to have Exchange and a website at you location have have more those services offsite.

Your website host is now probably on a company like Godaddy or Network Solutions using virtual hosting. So your website does not have an fixed IP address. You can check with your web host.

 If so, when folks go to the website, they go a a general web host ip address. A table on the web server sees " bluecanyonpartners" and re-directs them to the directory containing your website. This is why http://www.bluecanyonpartners.com/ changes to http://bluecanyonpartners.com/. Notice the www is missing.
You can change the "host file" on your workstations to re-direct the browsers to go to the actual location of the website. It's like setting up the CNAME on the web host.

A local host file will bypass the normal DNS reference and go directly to the site.

http://en.wikipedia.org/wiki/Hosts_(file)

The hosts file is a computer file used in an operating system to map hostnames  to IP addresses. This method is one of several system facilities to address network nodes on a computer network. On some operating systems, the host file content is used preferentially over other methods, such as the Domain Name System (DNS), but many systems implement name service switches to provide customization. Unlike DNS, the hosts file is under the control of the local computer's administrator.

This tend to happen when you start moving different web servers offisite.

Author

Commented:
I found a go-around fix for this issue. I manually created and entry, in the hosts file of my computer and was able to open the website. I will need to manually create this entry for every computer on our LAN, in order for the computer to open our company website. I do not yet know an automatic way to do it.

Without this entry, a request to open bluecanyonpartners.com, will only go to our local domain controller, as this is also our local domain name in the office

Changing the hosts file was tricky for me. The hosts file was read-only on the XP machine. I changed that in the file properties and that worked for XP. For Vista, I copied the hosts file to my desktop, edited it and then copied it back to the default location, replacing the original.

I cannot thank you guys enough for your comments.
is your internal domain called bluecanyonpartners.com by any chance?

if your local active directory domain is called bluecanyonpartners.com and you create a local entry in the hosts file, you will probably break active directory authentication from the workstations

Author

Commented:
Yes Jake, it is. A ping to bluecanyonpartners.com inside my LAN, only yields a successful roundtrip to the domain controller and back. Except I change the hosts file on the local client, as stated above.

Our company website redirects from www.bluecanyonpartners.com to bluecanyonpartners.com
you are better off getting in touch with your hosting provider and ask them to take away the redirection from www.bluecanyonpartners.com

you've also learnt a valuable lesson here - don't call your internal domain the same as your external name
any particular reason for not awarding any points on this???

Commented:
bobox00,
 
EE is experimenting with a new closing process.  If you are in the "control" group, then if you see an "Accept as Solution" under each Expert comment, clicking that will still allow you to allocate points to the Experts.

If you do not see that, then you are in the test group, and you should see a "was your question answered" link at the bottom.  If you click yes, then you can pick the comment(s) that answered the question, which may include your own.
 
 Vee_Mod
Experts-Exchange Moderator

Author

Commented:
I have tried closing and assigning points, but the new/test system on EE wont let me.
lol...you're not on your own with problems awarding points bobox00.

it's happened with others as well :)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial