IIS 6.0 prompting for Windows Authentication when accessing CITRIX Web Interface 5.1

steve_o76
steve_o76 used Ask the Experts™
on
Hello all,

I have a Windows 2003 Server /SP2 with CITRIX Web Interface 5.1 installed (I have PS on another server as well).  The server is part of a domain.  When I try to access the site, I keep getting prompted for a username and password by Windows Authentication.  I am trying to allow any user access to the web interface page and then they enter credentials to access published applications.  

If I cancel the WinAuth, I get 401.3 ACL error.  The issue is that I cannot have my users authenticating 3 times to get published applications.

For Troubleshooting, I have done the following:
1. Added IUSR (NTFS permissions) to C:\Inetpub\wwwroot - Full control
2. Removed Windows Authentication from the entire website in IIS Manager
--*Doing this gets rid of the WinAuth, but it goes straight to the 401.3 error

I have run the IIS troubleshooting application from Microsoft, no help
I have changed permissions more times than I can count.
I have changed my browser settings on my laptop because I read that it can cause problems like this by the way it is configured.

On the flip side, if I enter an ID and PW at the WinAuth, I immediately get to the Web Interface Logon page.  I enter my credentials there as well and I get to my published apps.  I click my published app and I have to authenticate again, and it comes up.  

This is the behavior I want except for the WinAuth when you first hit the site.  I have a certificate for the site as well.  If you need any more information about the setup, I will be happy to share what I can.

I am at the end of my rope.  
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
Example of what I am getting....

Author

Commented:
Sorry,,,
CTX124022-1.gif
Tray896SharePoint Engineer

Commented:
I would add wi.domain.com to your local intranet zone in IE by going to Tools-->Internet Options-->Security.  Click on Local Intranet-->Sites-->Advanced, and enter http://wi.domain.com to the list.  Then click on Custom Level back at the Security tab in IE, and scroll down to the bottom and make sure that 'Automatic logon in Intranet Zone' is selected.'

After that it should allow you to authenticate to the site without a prompt when using Integrated Authentication.  It sounds like your permissions are fine since you said it allows you in when you manually type in the username and password.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
Thanks for the suggestion Tray896, unfortunately that did not solve the issue.  I had tried that solution before and it didn't prove to be successful.
Solution: User Rights conflict was causing the error.
Steve o --- Can you give a little more explanation to what user rights issue was causing the problem and what you did to fix this? I am having EXACTLY the same problem. It just popped up after stopping and starting IIS one day. This is killing me. Any help would be greatly appreciated.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial