We help IT Professionals succeed at work.

Website asking for credentials

lino_evolution
lino_evolution used Ask the Experts™
on
A website that was working fine is now asking for username and password.

The security settings HAVE not been changed.

That being said, enable anonymous access is checked with the proper account, which is the same account on the folder settings that has full access.  Integrated Windows authentication is also checked.

Why all of a sudden is the site asking for credentials.

The ONLY modification was changing the app pools and the .NET version, which since have been changed back to its original settings.

Please assist.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Tray896SharePoint Engineer

Commented:
If you have both anonymous and integrated checked and you are getting prompted, then the most likely causes are that neither the anonymous IUSR account nor the domain users/authenticated users group have access to the content.  Since you said the anonymous account does have full rights to the content, then that should obviously work and not prompt anyone.  Have you checked to see if the anonymous account is locked out?  That could certainly cause this type of behavior.

Author

Commented:
We host many sites on our web server with that same account, no other website is affected by it.
Tray896SharePoint Engineer

Commented:
Maybe somehow this website got added to the local intranet zone on some client machines, and is trying to auto login with their AD credentials rather than anonymous?  I would check that and play around with the IE settings at Tools-->Internet Options-->Security.

If you type in a username and password at the prompt does it work?

Author

Commented:
Yeah, If I type in our admin and pass it works
what happens if you press cancel when it prompts does it let you browse ? Popup is because of Integrated Authentication checked, uncheck n try if it works.
Permissions on subfolders were lost so what I had to do was go into advanced and apply the same settings to all the subfolders and files.

I do not know how this happened.