We help IT Professionals succeed at work.

Need instructions - how to connect Windows 98 to Windows Server 2008 Std.  Domain

2,036 Views
Last Modified: 2013-12-23
I have a Windows 98 (non-SE) IBM Thinkpad that needs access to our Windows 2008 Server.  I have created the user account on the Server but cannot get mapped drive on Windows 98 machine to connect.  Keep getting the password prompt and current password will not authenticate.  Have tested user account and password on XP machine to confirm okay.
Comment
Watch Question

Commented:
Have you installed DSCLIENT utility on the Windows 98 workstation?

Take a look at the following URL that provides information on this client.
http://support.microsoft.com/kb/555038

Commented:
Also:

Check group policy and disable the policy "do not allow Lan Manager Hashes on next password change".  Then change the password of the user account in order for the Lan Manager hash to work.

Note, too, that LM hashes weaken security.
Lance McGrewIT Director

Author

Commented:
DSCLIENT utility installed.

Unclear about where and how to configure GP.  I found a utility called poledit.exe however I need help on how to use if this is the right approach?

Commented:
Did DSClient fix issue?  If so, don't mess with group policy.

On server, go to start / administrative tools / group policy management

Expand "domains' until you see 'group policy objects'.  under that, right click/edit "default domain policy' (not default domain CONTROLLERS policy)

Go to computer config / policies / widnows settings / security settings / local policies / security options.

Go to the network security: settings in the list of policies, and you'll see "do not store lm..."  it's enabled by default.  disable it.  



Lance McGrewIT Director

Author

Commented:
DSClient did NOT fix the issue.

Disabled the policy "do not allow Lan Manager Hashes on next password change".  Ran gpupdate /force.

Tried login on laptop with both domain\user and just user however when I try to map a drive, still getting message The password is incorrect. Try again.

Commented:
after you did the policy disable -- did you change the password on both sides?  Do that -- so it stores the LM hash again.
Lance McGrewIT Director

Author

Commented:
Changed password on both client and server - still get message when trying to map drive:

You must supply a password to make this connection.   When I type in the password and click OK - The password is incorrect. Try again.

Something else noticed.  When I log on using format  domain\username - Change Password is grayed out and I do not have Change Password disabled on server. When I log on using format username without the domain\  - Change Password is available under Control Panel, Passwords.
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Lance McGrewIT Director

Author

Commented:
net use x: \\server\share  password   - DID WORK

The syntax /user:domain\username is an unknown command in Windows 98.

Commented:
Been a while since i messed with windows 98.  glad you got it working :-)
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.