We help IT Professionals succeed at work.

CentOS - Subversion - Install from Source - sqlite must be compiled with thread-safe

1,382 Views
Last Modified: 2013-11-25
I have a CentOS 4.8 box, it uses a WHM cpanel so in order to install subversion I need to do so from source. I've done this before on debian boxes without issue, but here no luck.

I compiled sql lite as

./configure --prefix=/usr/local/sqlite --enable-threadsafe

Open in new window


and have also tried

./configure --prefix=/usr/local/sqlite --enable-threadsafe=yes

Open in new window


the subversion compile looks like

./configure --prefix=/usr/local/subversion --with-apxs=/etc/httpd/bin/apxs --with-apr=/usr/local/apr/ --with-apr-util=/usr/local/apr-util/ --with-neon=/usr/local/neon/ --with-ssl --with-sqlite=/usr/local/sqlite

Open in new window


but I still end up with

Transmitting file data .svn: Commit failed (details follow):
svn: Couldn't perform atomic initialization
svn: Couldn't perform atomic initialization
svn: SQLite is required to be compiled and run in thread-safe mode

Open in new window


any thoughts?
Comment
Watch Question

CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
sqlite needs to have SQLITE_THREADSAFE macro set to 1.
http://www.sqlite.org/faq.html

Have you tried to get the RPMs?
http://mirrors.finalasp.com/CentOS/4.8/os/i386/CentOS/RPMS/

I gather you prefer to use the newer versions since you are compiling from source?

Author

Commented:
Hey arnold,

yea the SQLITE_THREADSAFE is supposed to be set to 1 by compiling with --enable-threadsafe. Do you know how I can check if it is or not via the sqlite command prompt?

Can't use the RPMs, WHM cpanel has installed things on the machine that won't allow the subversion RPM to install.

CERTIFIED EXPERT
Distinguished Expert 2019
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Yea it's in there in the config.log

THREADSAFE_FLAGS='-DSQLITE_THREADSAFE=1'

I presume it's looking at the correct install, as it was originally giving me a version error until I remembered to specify the path to this specific sqlite in the configuration of subversion.
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Uninstall the centos provided sqlite packages and see if the issue goes away.

Commented:
On centos try with yum. It will show you if any dependencies are required and will auto install svn.
# Use the below command
yum install subversion

 
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.