Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Recovering a mailbox from backup

Avatar of systemsopx
systemsopx asked on
Exchange
20 Comments1 Solution825 ViewsLast Modified:
Hello,

We are running Exchange 2007 ver 8.2 (Build 176.2). I am trying to recover a mailbox from a back up. We use Commvault for backup. I created the recovery storaage successfully but i am not able to mount the data base.  I get the following error message below.

Error encountered while trying to mount the database () in the recovery storage group (Recovery Storage Group). Error message is: Exchange is unable to mount the database that you specified. Specified database: () Error code: MapiExceptionCallFailed: Unable to mount database. (hr=0x80004005, ec=-544)
..

I also see the below application logs.

Error 0xfffffde0 starting database "Recovery Storage Group\**" on the Microsoft Exchange Information Store.

Error 0xfffffde0 starting Storage Group /DC=com/DC=/CN=Recovery Storage Group on the Microsoft Exchange Information Store.
MDB failed to start.

MSExchangeIS (276) Recovery Storage Group: Attempted to attach database ".edb' but it is a database restored from a backup set on which hard recovery was not started or did not complete successfully.

Let me know what you guys think. I am thinking it's not a sucessfull backup. I tried restoring the backup twice from the same date. I was thinking of trying a backup from another date.
ASKER CERTIFIED SOLUTION
Avatar of Aj8787
Aj8787

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 20 Comments.
See Answers