We help IT Professionals succeed at work.

Server's clock is not synchronized with the primary domain controller's clock

p1admin
p1admin asked
on
6,543 Views
Last Modified: 2012-05-09
Unable to access any network resources due to this time error. This seems to affect only Windows 7 clients. They are able to access the internet but not intranet.

I've verified time on all DC's, ran: net time /domain /set , rebooted, flushed dns.  I even had another laptop use that ethernet connection (running xp) and able to access intranet.

I checked other Windows 7 users and they all have the same problem.

Any help is appreciated.
Comment
Watch Question

Commented:
Afternoon,
First question which i'm sure you've tried is making sure any firewall on the Windows 7 clients is disbaled, and testing.
I haven't seen an issue like yours before but a couple of commands you can try on one of the clients, you'll need to open a command prompt as an administrator, then try the following
w32tm /query /source - this should list your time source, in this case your DC
w32tm /resync - should attempt to sync the time and if there are errors list them
w32tm /monitor /domain:<domain name> - replace <domain name> with your domain, ie testdomain.com. this will do a couple of things, query AD for DCs, then attempt to receive the time and show any offset between local time and their time
you can also enable logging of the sync process
w32tm /debug /enable /file:c:\<folder name>\<file name> /entries:0-300 /size:2000 - this will create a logging file in c:\<foldername>\ called <file name>, entries 0-300 means log everything, and size 2000 means use circular logging with a max file size of 2kb. this may provide extra information to help you troubleshoot. when done disable logging with
w32tm /debug /disable
If any of the above shows time related errors let us know and it may help lead to a fix

Commented:
Disable Ipv6 on Windows 7 machine

Author

Commented:
Thanks for the tips on the time. It has synch with the DC.

I disabled IPv6 on all adapters.

your help is much appreciated!


I now get this error: System error 2457 has occurred

Author

Commented:
Thanks all. i have a solution and a workaround. I started by adding host entries for the Samba shares and it worked so I wnet and added dns entries to fix it company wide.

Thanks Bartko for you time tips and eddie 86 for you IPv6 suggestion.
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.