Link to home
Start Free TrialLog in
Avatar of u795696
u795696Flag for Netherlands

asked on

"A policy is in effect on your computer which prevents you from connecting to this printer queue"

Dear Experts,

I am seeing a strange issue on my domain which I do not understand.
We have two printer servers (old & new), both servers are Windows 2003.
When we try, as a non-admin, to install a printer, with non-standard drivers, from the new print server we get prompted with the message :
A policy is in effect on your computer which prevents you from connecting to this printer queue
Installing the printer from the old server does not give this message.
Installing as an Admin is fine as well. Once the printer is installed, we are not bothered again and can add the printer just fine from both servers. My guess is that if the driver is once installed it won't bother again to try unless the driver is updated.
As a test I created seperate containers in AD for both the computer and user object. The test computer and test user were added to these new containers and all group policy settings were disabled on these containers.Unfortunately, even without any applied policies, the problem still persist.

I have tried adding "point and print restrictions" to these test containers. Added trusted servers, tried to disable, enable, hit every checkmark I could fine on both the User settings as the Computer setting of the point and print restrictions but unfortunately the problem still persist.

I am puzzeled by this and am seeking some fresh insights.
Any help would be grately appreciated!

Thanks

Remko
Avatar of Awinish
Awinish
Flag of India image

You can try rsop.msc & see the setting applied from GPO's.

Check below KB too.

http://support.microsoft.com/?kbid=319939
Avatar of u795696

ASKER

Thanks for your comments.
Accoring to the article an incorrect dnslookup zone might be a cause of this error.
We have double checked the DNS records and these are configured correctly.
Also there are NO policies applied to either the computer object as to the user object.

If we try the same settings with Win7 clients the point & print restrictions work without any problem. If the Point & Print restriction is disabled, the Win7 client can install printer drivers without 'elevation'
If the Point & Print restrictions are enabled, the Win7 client needs admin rights to install.
So far so good, but no matter what the settings are on the XP client, the error message stays.
Be advised that from the old mail server everything works just fine. It is just from the new mail server.
I therefore think the problem is not policy related.
Problem is that I do not know what else could be the source of this problem.

Remko
There can be problem with the system also. Check & scan with latest AV.
Avatar of u795696

ASKER

This would mean that we have this problem on multiple PC's. Several XP machine show this problem. Also it would not explain, why it works for one server and not for the other.
ASKER CERTIFIED SOLUTION
Avatar of u795696
u795696
Flag of Netherlands image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial