We help IT Professionals succeed at work.
Get Started

Cannot RDP to W2008R2 Server 'Computer Name' but can to its IP Address

832 Views
Last Modified: 2012-05-10
Am setting up a test environment and have 2 W2008 R2 servers currently going.  One has AD DS installed on it.  Can RDP from my W7 laptop to that one fine.  Am now working on a second one which will ultimately be the Exchage Server, but I can't RDP from my laptop to it using the Computer Name (error:  Remote Desktop cannot find the computer..... ).  If I RDP to the IP Address it works.  I've looked in the event logs on both servers and can't

One anomally, I set the server up yesterday, no-go on teh RDP then, but this morning first thing I RDP-ed in using the Computer Name and it worked.  I then added the File Service & Application Services roles and restarted the server, and now only the IP Address RDP will work again.

This is my first time setting up a multiserver enviro, what am I doing wrong/missing?
Comment
Watch Question
This problem has been solved!
Unlock 2 Answers and 13 Comments.
See Answers
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE