network connection problem

I am running vista 32 bit o/s. It appearrs as though I am connected to the internet . I have installed firefox from a flash drive and it loads web pages I have also gone to cmd prompt and pinged Yahoo and received a reply. However when I try to look at my adapters connection or properties or I go to network and sharing center I receive the following.
connection status unknown
class not registered.
I cannot get anything to load through internet explorer. I have run Malwarebytes and found and removed numerous problems also. How do I correct this problem with the connection icon or network and sharing center problem
begearra123Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SysExpertCommented:
1) I would check that IE does not ahve a proxy set for it- many malwares do this.

2) Run trend Micro house call from firefox.

3) You may also see if you can do a repair of IE via the add/ remove programs

I hope this helps !
0
begearra123Author Commented:
There is no proxy set in IE
iam attempting to install housecall right now
I have allready installed a vista ie 8 install and that did'nt work
 I will let you know about the housecall results if it even lets me install it
0
begearra123Author Commented:
I have run the housecall but it found no threats.
any other ideas I can try
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

joinaunionCommented:
Open command prompt then type  net localgroup administrators localservice /add
Space between localservice and /add
To verify type net localgroup administrators
Reboot computer
If this did'nt work do the exact same in safe mode then reboot.
0
SysExpertCommented:
XP TCPIP fixes reset NIC and TCPIP reset  Fix TCPIP reset
From johnb6767

What I like to do on any network problem....Is to reset it ALL....

netsh int ip reset reset.log
netsh firewall reset
netsh winsock reset

Then remove ALL NIC's from the device manager..
In the Device Manager, select View>Show Hidden Devices

(If the Show Hidden devices is not presetn, do the following command from a command prompt..)

start>run>cmd
set devmgr_show_nonpresent_devices=1

More information on that command here....
Device Manager does not display devices that are not connected to the Windows XP-based computer
http://support.microsoft.com/kb/315539
http://support.microsoft.com/kb/317518/en-us


Go back to Network Adapters, and make sure your adapters are all gone, including any older ones. (there will be several ' miniport' devices that are not able to be uninstalled....)
Once they are all gone, reboot and let Windows reinstall them...

Thats a total rebuild of your network connections, to hopefully correct any problems with Basic connectivity.

0
jeremyjared74Commented:
Switch your OS to UBUNTU. It is free and has a ton of free software. I switched yesterday, and I am never going back. You can install it alongside Windows and boot into either OS. Here is the link: http://www.ubuntu.com/desktop/get-ubuntu/download
0
begearra123Author Commented:
thank you loinaunion unfortunately your idea did not work.  I am still experiencing the same symptoms.
also thank you sysexpert unfortunately your solution did not work either. I cannot see the network adapter in network connections folder there is nothing that displays and I am still getting class not registered. is there any other ideas I can try.
 as far as going to ubuntu I am familiar as well having a multi boot machine myself, however the machine in question does not allow me that privilage or liberties.
0
SamMacPCCommented:
Could you use an Ubuntu livecd? for the record, I think it's a terrible suggestion. I would actually recommend running Network Diagnostics from IE. Try to go to a webpage. when it gives an error, run the troubleshooter, see what it says and post back.

Can you list the adaptors here?

Can you check your DNS settings? Sometimes malware messes those up as well. If you see unfamiliar DNS servers, change your passwords as they may have been compromised.
0
MaurizioSchmidtCommented:
youve installed the newest NIC drivers ? do you have DHCP or fixed ip ? first make sure the correct NIC drivers are installed, better reinstall them.
0
SamMacPCCommented:
corrupted drivers seem extremely unlikely. The reason I want you to list the adaptors is that sometimes virtual ones get added in that can gum up the works. DHCP vs. fixed IP is a good one. Basically, we want to simplify your network configuration. If you do reinstall, reinstall both the wireless and the wired.

--Sam
0
jeremyjared74Commented:
Ubuntu is available for any machine I believe. I installed it on a Vista Lenovo PC. I am not saying to get rid of Windows all together, is is just nice to have a System that I know will work. Plus I am in a financial slump right now, and I am studying web development. UBUNTU offers all the tools I kneed for free. Not Demo, but Free. When I installed it on my hard-drive instead of running it off of a cd, it is noticeably faster than Vista.

UBUNTU offers Edubuntu which is an Educational OS. It is also free. I live in a small country town where the schools have taken a huge hit because the economy. Don't be afraid of something just because it is unknown or not popular. If truly is an up and coming OS. You can run it from a Flash Drive even.

I don't want to stray from the question, it was just an alternative solution. I guarantee if you tried it you wouldn't regret it. Either way I wish you luck.
0
jeremyjared74Commented:
Here is your fix.
  1. Go to Device Manager
  2. Find your Network Adapter
  3. Right click on the Adapter
  4. Choose uninstall
  5. Right Click and choose Scan for hardware changes
0
SamMacPCCommented:
will you please stop spamming the comments with ubuntu recommendations? We're trying to fix a windows system here.

Thanks.

--Sam
0
jeremyjared74Commented:
You are not to reply to a Expert, It is board policy. I am not "spamming". As I said  it was a suggestion. I finished with a way to fix the problem. This is not a board for arguing. In the future refrain from engaging other Experts.
0
begearra123Author Commented:
the adapter is an intel pro 10/100 ve and it is integrated there is no other ie:wireless. I have removed the adapter out of device manager as was the suggestion from sysexpert. As far as trying ubuntu I have and do I have it on a multi boot machine as I mentioned before. This particular machine is not mine so concequently using it on this problem as a fix is not an option. I do appreciate you input though, and yes ubuntu is a great alternative.
 I cannot even get to my adapters properties in network connections to see if the ip has been compromised. I open up network connections and there is nothing listed.As far as errors on a web page when I click internet explorer I get nothing but a blank page, and it is very difficult to close once opened. when I open firefox it will get on the internet and surf away.
0
joinaunionCommented:
What type of computer is this?(model#)
 
0
joinaunionCommented:
Ok right click the network icon on your desktop then properties then on the left under tasks click diagnose and repair then post back if there is a error and any codes if it produces one.
0
joinaunionCommented:
You can go here with the problem computer use firefox then click on check your system for the latest updates.Post back
http://www.intel.com/support/detect.htm 
0
SamMacPCCommented:
if there is nothing in network connections, you need to go under task and click "setup new connection" and setup an internet connection based on LAN.

This should work.

--Sam
0
begearra123Author Commented:
thank you loinaunion but I cannot right click on my network icon and get it to do anything all it says is class not registered and the adapter to be able to go to properties is not even there.
 thank you sammacpc. I have tried your idea but when I go to setup a connection to the ineternet or network it says there is allready a connection if I go to set one up anyway the only choice it gives me is create a dial up one.
 Joinaunion I will run the link tommorrow for it is late and I will post back tommorrow.
this is an emachine desktop
0
begearra123Author Commented:
unfortunately it does'nt seem that anyone is going to be able to help me with this situation. It appears that the only solution is to reformat and reinstall.
Thank you everyone for your time and effort, but it looks like this one did not get solved
0
SamMacPCCommented:
let's try a few other things. if you're willing?
0
SamMacPCCommented:
You may want to try a windows repair or sfc \scannow

http://social.answers.microsoft.com/Forums/en-US/vistanetworking/thread/9f1ee7c4-f850-4ba8-890a-db979754fbd6

"class not registered" turns up useful Google results.
0
begearra123Author Commented:
ok I'm willing I havent done anything to it yet. I should tell you though I am finding out that it is not just a network connections missing problem. I have tried to install avira through normal and safe mode as well it will not install says there is microsoft redistributed software install problem. I also tried to install IE 8 and it will not install either. I also went to user accounts to attempt to setup a new user it is not able. sounds like its a bit bigger then originally thought.
0
begearra123Author Commented:
I also tried to run the backup feature in tools on disk c and it would not see the disk c it saw the recovery disk and the external usb partitions.Consiquently it would not let me do a back up that way. I was however able to do the recovery dvd creation and drag the docs folder over to the external device to backup 19gb of info and prepare for the worst.
0
SamMacPCCommented:
ok hang on just a second. go to the start menu's search box, type regsvr32 ExplorerFrame.dll.

reboot.

see if that fixes any or all of these problems.

If it does, great.

If it doesn't, run sfc -- system file checker.

http://www.updatexp.com/scannow-sfc.html

If it doesn't, run a Windows repair. tap F8 while your starting up, and go to repair this computer.

You may also find the link I posted useful.

--Sam
0
begearra123Author Commented:
currently it is running the scan. I wiill get back to you when it is done and thank you for sticky with me on this.
0
jeremyjared74Commented:
Have you checked to make sure all of the apropriate Services are running? It could be that a few services that are required are not running. Maybe worth a shot.

Here are a few good link: Service Tips , Tips and Tweaks.  
0
begearra123Author Commented:
scan reported that it did not find any integrity errors so I am doing the repair right now I will get back to you
0
SamMacPCCommented:
jeremyjared is right about services. In my initial link, it discusses which services to turn on. But I figured a repair was the more expedient way to fix the problem.

--Sam
0
begearra123Author Commented:
I have looked at services I saw that netman / network connections was stopped. this was just one example: I went to right click and start the service: I received class not registered. I was able to do it in safe mode but this still did not fix the problem is there a way to allow all services with key commands?
0
jeremyjared74Commented:
I am not sure. I know there are 3 places they have settings on Vista. In the Services Tools. In the MsConfig area, and in the Control Panel/turn off Windows features. It is strange there are so many settings off in this computer. Must be some type of a Virus. The first thing I do when I think I have a Virus is:
  1. Start MsCongig, go to startup and disable all (restart)
  2. Manually delete all Temporary Internet Files in My user folder under Roaming. I always check all users and all instances eg; local-local low-roming. Even though there usually isn't anything in any of them except Me-Roaming.
  3. I do a search throughout my entire file system looking for any leftover software packages.
  4. The last one is a little tricky. If this isn't your computer it will be hard for you. I make a list of my programs I have un-installed, go to the Registry and choose edit, find, then do a search for any entries that were left behind. I always back up the Registry before deleting. If I am unsure of a registry entry, I will just delete the Value and leave the entry there blank.
With all of the steps you have tried, and it's still is not working. I am thinking it is a registry value, but finding this is almost impossible. And it is a real crap-shoot if you try a "free" registry editor. If I have any more ideas I will post them for you. Good Luck
0
SysExpertCommented:
1) I would run a DIsk check using something like the free UBCd
 

UBCD Free vendor and other diagnostics and utilities
www.ultimatebootcd.com

This is to rule out hard drive issues which may have caused corruption

If the drive is oK, then try a windows repair install.

I hope this helps !
0
SamMacPCCommented:
this will tell you what services to turn on.
http://social.answers.microsoft.com/Forums/en-US/vistanetworking/thread/9f1ee7c4-f850-4ba8-890a-db979754fbd6

did you already do a windows repair? Did it not work?

--Sam
0
begearra123Author Commented:
I had tried all suggestions that where presented and unfortunately nothing seemed to work. I appreciate everyones help in this matter.
0
begearra123Author Commented:
I forgot to mention I ultimately had to do a reformat reinstall.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Vista

From novice to tech pro — start learning today.