Error The Autodiscover service could not be contacted.

Nordicit
Nordicit used Ask the Experts™
on
help please,
i have exchange07 and outlook07.
i cannot get this autodiscover service up and running.
---------------------
Information About to test AutoDiscover with the e-mail address Administrat....
Information Testing server mail.abc.com with the published na....
Information Found a valid AutoDiscover service connection point. The AutoD....
      Error When contacting https://mail.abc.com/autodiscover....
      Error The Autodiscover service could not be contacted.
---------------------
found some article on net, just that i cant follow.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
BusbarSolutions Architect

Commented:
do you have audodiscover.abc.com configured in the public DNS and published that name through the firewall, also make sure that audodiscover.abc.com is included in the certificate
create a cname record for  your exchange server and type the
"autodiscover"  that points to the host a record of your exchange server
and then have a certificate that supports mumtiple subject names

more options discussed at
http://technet.microsoft.com/en-us/library/bb332063(EXCHG.80).aspx 

Thank you
Marc DekeyserSr Premier Field Engineer

Commented:
Run the test-outlookwebservices | fl and post that here. Without seeing the complete error it's hard to troubleshoot this. Additionally, are you running an ISA server?
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
- Go to https://www.testexchangeconnectivity.com/ and perform the Outlook Auto-discovery test and post the output here.

- Does you have 3rd party UCC certificate or the self signed?


Author

Commented:
here are aome details guys on my setup.

Notes:
1. my domain is abc.com
2. smtp address is abc.com.sg
3. alrdy have public dns A record "webmail.abc.com.sg" pointing to exch (for OWA use)
4. im using a self signed cert
5. my outlook clients also have the popup for username &pswd.

--------------------------------------------------------------------
this is the full results of test-outlookwebservices | fl


Id      : 1003
Type    : Information
Message : About to test AutoDiscover with the e-mail address Administrator@abc.com.sg.
Id      : 1007
Type    : Information
Message : Testing server mail.abc.com with the published name https://mail.abc.com/EWS/Exchange.asmx & .
Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https:// mail.abc.com /autodiscover/autodiscover.xml.
Id      : 1013
Type    : Error
Message : When contacting https:// mail.abc.com /autodiscover/autodiscover.xml received the error The remote server returned an error: (401) Unauthorized.
Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.
--------------------------------------------------------------------

Sr Premier Field Engineer
Commented:
2 Options:
1. You create a new certificate with the following 4 names:
+ external FQDN of the mail server
+ Internal FQDN of the mail server
+ Netbios of the server
+ autodiscover.abc.com

2. The following article: support.microsoft.com/kb/896861

Author

Commented:
Hi , i've done the following:

1. created a new cert with 4names
2.created a cname pointing to host server
3. created registry key DisableStrictNameChecking & DisableLoopbackCheck

still stucked with same error:
------------------------------------------------------
Id      : 1019
Type    : Information
Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https:// mail.abc.com /autodiscover/autodiscover.xml.
Id      : 1013
Type    : Error
Message : When contacting https:// mail.abc.com /autodiscover/autodiscover.xml received the error The remote server returned an error: (401) Unauthorized.
Id      : 1006
Type    : Error
Message : The Autodiscover service could not be contacted.
------------------------------------------------------

PLEASE HELP, let me know if u need more info.

thanks..

BusbarSolutions Architect
Commented:
looks like authentication issue
can you remove hte autodiscover virtual directory and re-create it
get-autodiscovervirtualdirectory | remove-autodiscovervirtualdirectory
new-autodiscovervirtualdirectory
Marc DekeyserSr Premier Field Engineer

Commented:
Did you reboot after disabling the strict name checking?
Marc DekeyserSr Premier Field Engineer

Commented:
On the other hand, if you made a new cert that should not be impacting... could very well indeed be related to the authentication settings...

Author

Commented:
thnks guys, gettings some improvements here, latest  results test-outlookwebservices | fl
------------------
Id      : 1006
Type    : Information
Message : The Autodiscover service was contacted at https://mail.abc.com/autodiscover/autodiscover.xml.

Id      : 1013
Type    : Error
Message : When contacting https://mail.abc.com/EWS/Exchange.asmx received the error The request failed with HTTP status 401: Unauthorized.

Id      : 1016
Type    : Error
Message : [EXCH]-Error when contacting the AS service at https://mail.abc.comm/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

Id      : 1015
Type    : Success
Message : [EXCH]-Successfully contacted the OAB service at https://mail.abc.com/EWS/Exchange.asmx. The elapsed time was 0 milliseconds.

Id      : 1014
Type    : Success
Message : [EXCH]-Successfully contacted the UM service at https://mail.abc.com/UnifiedMessaging/Service.asmx. The elapsed time was 0 milliseconds.

Id      : 1006
Type    : Success
Message : The Autodiscover service was tested successfully.
------------------


Author

Commented:
do i need to recreate the the EWS directory this time?
will it affect my outlook clients?

pls advise the next action,
BusbarSolutions Architect

Commented:
yes try to recreate it and see what will happen

Author

Commented:
guys, thanks for all the help.
since my main problem is solved, i'll be closing this thread. cheers!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial