Asterisk dialplan: Back to DISA after remote party hangup

Hello experts,

In my Asterisk dialplan:

[authorised]

exten => s,1,Playback(access-granted)
exten => s,n,DISA(no-password,privileged_context)

Say that user called 00812345678.

When remote party 00812345678 is hanging up, the call both legs are being hung . Is it possible to let caller to resume back to DISA again after the remote party hangs up? I remember that somebody made this for me before, but I forgot how it was.
MuhajreenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

samdartCommented:
See if this works?

[authorised]

exten => s,1,Playback(access-granted)
exten => s,n,DISA(no-password,privileged_context)
exten => s,n,Goto(s,2,authorised)
0
nasirbestCommented:
replace your dialplan with following

[authorised]
exten => s,1,Playback(access-granted)
exten => s,n(dial),Dial(Local/disa-ext@authorised,3600,g)
exten => s,n,Goto(dial)

exten => disa-ext,DISA(no-password,privileged_context)

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MuhajreenAuthor Commented:
Thank you both.

@samdart: Your solution didn't work, the call hangs up before proceding to the next priority.

@nasirbest: You solution works partially, just a problem that after caller receives DISA tone, when he presses any single digit, it proceeds to the Goto(dial) priority and repeats again...... forever.

I think we are very near to the solution.
0
nasirbestCommented:
can you provide asterisk cli logs ?
0
MuhajreenAuthor Commented:
Thank you,

It was a mistake in the (privileged_context) name, now it's working fine !

Have a good night.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
IP Telephony

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.