Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1089
  • Last Modified:

Cant change default program to open file

Windows 7
Office 2007
Adobe 9.3

I have a system that wants to use Outlook as its default program. I tried to change the default program for pdf files in control panel but the option "always use this program" is greyed out.

Any ideas?
0
cnl83
Asked:
cnl83
  • 6
  • 5
  • 3
  • +1
1 Solution
 
pmaribeiroCommented:
Verify if your user has previleges to do this action (must be at least power user).
0
 
jcimarronCommented:
cnl83--See Xandragnis' post here
http://social.answers.microsoft.com/Forums/en-US/w7files/thread/8a84fcec-22df-4942-8e35-d98dbe96e327
You would scroll to AcroRD32.exe, then click on shell>read>command
And change the Data column in the right panel to
"C:\Program Files (x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe" "%1"  Including quote marks.


However, running SFC /SCANNOW from a command prompt might be a good first step to be sure all Windows files are not corrupted.
0
 
cnl83Author Commented:
I am administrator

This is unclear... There are not exe file names in this registry area.



In regedit: Navigate to Computer\HKEY_CLASSES_ROOT\Applications and find your .exe name.
Navigate under its name to shell>open>command. In the Default change its location to the actual location of the executable, hit okay and then try and reassociate the file type as you normally would.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
cnl83Author Commented:
The problem associated with the above post is not the same issue I am having. The always use this program option is greyed out.
0
 
pmaribeiroCommented:
did you install recently any hotfix on windows?
0
 
cnl83Author Commented:
Negative
0
 
LeeTutorretiredCommented:
Perhaps this MS article will be of help:

http://support.microsoft.com/kb/555076
"Always use the selected program to open this kind of file" checkbox are grayed out in Windows 2003

Or perhaps this page:

http://www.sevenforums.com/general-discussion/48263-always-use-program-open-kind-file.html
0
 
cnl83Author Commented:
That registry key it refers to is not present in win 7.
0
 
LeeTutorretiredCommented:
You can create it and set it to zero.  Or:  did you try the SevenForums web link I gave above?
0
 
jcimarronCommented:
cnl83--First of all, I think your main concern is to change the association of .pdf away from Outlook to Adobe Reader  (AcroRD32.exe). Whether the " always use this program" option is greyed out is really not important. What I am suggesting does not use that option.
Second, go back to
http://social.answers.microsoft.com/Forums/en-US/w7files/thread/8a84fcec-22df-4942-8e35-d98dbe96e327
Yes, Xandragnis' post discusses .exe , but I gave you the instructions how to modify them for .pdf.  It really is quite simple if you just follow the instructions in my first post.  Or I will state them slightly differently (and specific to .pdf) as follows:
Modifying Xandragnis you would
In Regedit: Navigate to HKEY_CLASSES_ROOT\Applications and find AcroRD32.exe (right near the top).
Navigate under its name to shell>READ>command. In the Default column (right panel) change its location to the actual location of the executable (which I gave you as
"C:\Program Files (x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe" "%1"  Including quote marks) and
hit OK.  
0
 
jcimarronCommented:
cnl83--If you have any questions about my last post, please let me know.
And before you do anything in the Registry it is a good idea to back the Registry up so that if you have any problems after that, you can restore the Registry to its state before you made the changes.
Registry backup:  From the Registry Editor window, click File|Export and follow directions.  You will have created a .reg file.  To restore the Registry you right click on the .reg file and then Merge.
0
 
cnl83Author Commented:
There are no keys entries or anything under the application folder.... that's why I said it was unclear. This windows installation is fresh. About a week old.
0
 
jcimarronCommented:
cnl83--It is Applications (with an S).  It is in the group in  HKEY_CLASSES_ROOT right after the list of all file types (which does have "application", but that is not what you want).
0
 
jcimarronCommented:
cnl83--And you may have to modify the Data entry "C:\Program Files (x86)\Adobe\Reader 9.0\Reader\AcroRd32.exe" "%1"  if C:\ is not where the AcroRD.32.exe file is.
0
 
LeeTutorretiredCommented:
You didn't respond to my post about creating the key and setting it to zero, nor about using the sevenforums tutorial.  Any more feedback?
0
 
cnl83Author Commented:
Sorry I did not respond. I tried your fix but it did not work. The solutions is on this page.

http://www.sevenforums.com/tutorials/19449-default-file-type-associations-restore.html
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 6
  • 5
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now