Solved

the driver detected a controller error on device harddisk1 dr1

Posted on 2010-08-12
8
5,520 Views
Last Modified: 2016-06-26
Server is an HP ProLiant DL385 G5 running Server 2008 R2 64-bit on x2 Quad Core Opteron processors with 8GB RAM, and RAID-5 array.  The backup software is Symantec Backup Exec 2010, using 1TB external Western Digital Essentials drives.  I have tried 3 different (identical drives) and still have problems with the backup workinng properly for anywhere between 8GB - 72GB of backup, then it justs sits there.  When you cancel the backup job it will take 20 minutes up to 2 hours to successfully cancel the job.  Symantec software is responding during this time and only shows an error after successfully canceling the job.  That error is "the driver detected a controller error on device harddisk1 dr1".  I have installed a MS hotfix for USB driver issue that sounds exactly like my error, but only difference is that before I installed the hotfix I never received any errors.  The only other windows log event are ESENT event: 508 performance warning.  I am running Live Update again currently for Backup Exec.  I am also going to run the Western Digital diagnostics against at least 2 of the drives to see what results from extended test can be found.  All three of the external drives are brand new and the Symantec installation was just installed and has not worked yet.
0
Comment
Question by:DataPro
  • 4
  • 3
8 Comments
 
LVL 5

Expert Comment

by:Dunedan79
Comment Utility
I have never used a USB external for B2D in Backup Exec but I suspect that the USB interface is simply not robust enough. The same issue is seen on a PC using a SATA drive externally vs. internally, performance suffers quite a bit.

If you must use the USB drive for storage, do you have enough internal disk space to run the backups and then export (or copy) the media to the external drive?
0
 
LVL 4

Author Comment

by:DataPro
Comment Utility
I run USB external drives on all previous versions of Backup Exec and they work flawlessy.  This was the first to be installed with version 2010 since it is a brand new server.  Any other ideas?
0
 
LVL 5

Expert Comment

by:Dunedan79
Comment Utility
Do you have enough internal storage to try a B2D job of this size? It shouldn't fail either way but it would be interesting to see if the results were different.

Rereading your description it sounds like everything was fine before loading a MS hotfix. Can you back that out?
0
 
LVL 4

Author Comment

by:DataPro
Comment Utility
Before the MS Hotfix, it didn't work and no errors were logged.  Also the system would hang for 30 minutes to 2 hours on any programs that were attempting to use the external drive.  Eventually everything would just start responding on the problem programs.

After the MS Hotfix, an error is logged indictating failure in the external drives and the programs stay responsive.

Bottom line is the backups still don't work.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 5

Accepted Solution

by:
Dunedan79 earned 500 total points
Comment Utility
Is there any difference in base OS for previous Backup Exec versions that worked this way? Also if this is a new box have you checked for settings concerning USB in the system bios?
0
 
LVL 4

Author Comment

by:DataPro
Comment Utility
I am dealing with HP/Compaq on this problem currently, as I believe the problem is closer related to the USB ports Dunedan79 mentioned.  I ran HDtune benchmark on the drive and get only 0.8MB/s.  That is obviously contributing to the problem.  Will report more later.
0
 
LVL 4

Author Closing Comment

by:DataPro
Comment Utility
The problem was resolved using the Microsoft hotifx and setting the BIOS external USB ports to 2.0.  Not sure why they weren't set to begin with, but hey it works now.  All problems are resolved.
0
 

Expert Comment

by:kwongluk_pang
Comment Utility
I encounter the same issue but with IBM server and IBM KVM Switch, running on Windows 2012 R2 .

My Question
1) Which MS hotfix need to install?
2) How to set BIOS external USB ports to 2.0 for IBM System System x 3650 server.
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

Over the last few years, video game fans have found a new favorite pastime: Watching and creating live-streaming gaming sessions. Twitch.TV has emerged as an industry leader in making game streaming painless for those looking to share their Starcraf…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will walk an individual through the steps necessary to configure their installation of BackupExec 2012 to use network shared disk space. Verify that the path to the shared storage is valid and that data can be written to that location:…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

772 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now