Delayed emails in and out the exchange server

I have configured exchange server 2010, everything was working fine but all of sudden all the emails are being delayed.Can any one please solve this issue its very very urgent.
network16Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
endital1097Connect With a Mentor Commented:
check a message header like my earlier example
0
 
endital1097Commented:
from the management shell run
get-transportservers | get-queue

are messages queueing on your system
0
 
Sudeep SharmaTechnical DesignerCommented:
Also you could try this:

Send an email from your exchange to external address like gmail.com and check the message headers to find where the delay is.

It is possible that the delay would be at the recipient at and not at your end.

Below is a link which analyze the headers and could help you

http://www.mxtoolbox.com/EmailHeaders.aspx

Sudeep
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Alan HardistyCo-OwnerCommented:
Have you got DNS Forwarders added to the Forwarders Tab of your DNS server?  You could have DNS issues.
Did your ISP cut off SMTP port 25 for you without telling you?  This is a favourite trick of some ISP's.
Check by using telnet from a command prompt to my mail server:
telnet mail.sohomail.co.uk 25
telnet 87.194.160.198 25
If you can telent via both - that means your ISP has not cut off port 25.  If you can to the IP but not the FQDN then you probably have DNS issues.
Alan
 
0
 
network16Author Commented:
when i run get-transportservers | get-queue,  i get a error message command not found
0
 
endital1097Commented:
sorry, typo server not servers
get-transportserver | get-queue
0
 
network16Author Commented:
I have installed exchange server in one more computer for the other domain. Is it causing any problem
0
 
network16Author Commented:
1      *      JBXCHANGE.JB.LOCAL         JBXCHANGE.JB.LOCAL              mapi              8/12/2010 6:18:57 PM
2      *      JBXCHANGE.JB.LOCAL     x.x.x.x      mx.google.com       ESMTP      8/12/2010 6:18:48 PM
3      0 seconds      10.114.67.14          10.114.67.14                     SMTP      8/12/2010 6:18:48 PM
4      0 seconds      10.229.239.18     10.229.239.18               SMTP      8/12/2010 6:18:48 PM

can you tell me where is the delay
0
 
endital1097Commented:
i don't see any messages in these queues
i would look at an inbound message and view the headers

the example below shows when contoso.com received the message from obsmtp.com
you could then compare that time to when it was delivered to the mailbox

Received: from smtp.contoso.com (10.1.25.101) by hub.contoso.com
 (10.1.25.142) with Microsoft SMTP Server (TLS) id 8.2.254.0; Tue, 10 Aug 2010
 15:47:29 -0400
Received: from na3sys009aog113.obsmtp.com ([74.125.149.209])  by
 smtp.contoso.com with SMTP; 10 Aug 2010 15:47:23 -0400
0
 
Sudeep SharmaTechnical DesignerCommented:
Wel did you try my suggestion?

Send an email to external account and check the headers

Sudeep
0
 
network16Author Commented:
Yes i send an email to external address. and the header is copied and run in the header analyzer. The output is posted above
0
 
Sudeep SharmaTechnical DesignerCommented:
email received in 9 seconds is not a delay as per me

Quite possible that other recipient who complained that they are receiving emails with delay have some issue at their end.

So try to get the headers of the email which they have received with delay and check them.

Sudeep
0
 
network16Author Commented:
My other employees in canada saying that they have an delay about 30 mins. so, is there any problem with my server
0
 
Sudeep SharmaTechnical DesignerCommented:
Delay in receiving the emails or delivering the emails?

Sudeep
0
 
network16Author Commented:
Delay in receiving the emails.
0
 
Sudeep SharmaTechnical DesignerCommented:
Then would could check the headers of the email received by them and it would let you know where the delay was

sudeep
0
 
network16Author Commented:
Yes i will check it. I have one more warning

warnings

Get-OwaVirtualDirectory -ADPropertiesOnly
Completed

Warning:
The object JBXCHANGE\owa (Default Web Site) has been corrupted, and it's in an inconsistent state. The following validation errors happened:

Warning:
You must set a default domain if LogonFormat is set to UserName.
0
 
endital1097Connect With a Mentor Commented:
set-owavirtualdirectory JBXCHANGE\owa* -DefaultDomain YOURDOMAIN
0
 
network16Author Commented:
Thank you
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.