Solved

Open ports 443 and 102 on Pix 501

Posted on 2010-08-12
14
564 Views
Last Modified: 2012-05-10
Hi.

I have configured a Pix 501 to allow ipsec pass-through. It's taken me some time to figure that out but made it. Would like a little more assistance please. Below you'll see my current config. I need to open ports 443 and 102 to allow access to an https web site. Would you give me some direction ?

Ed

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
domain-name yabba.com
fixup protocol dns maximum-length 512
fixup protocol esp-ike
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit esp any any
access-list outside_access_in permit udp any any eq isakmp
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 111.222.33.444 255.255.255.0
ip address inside 555.66.77.888 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
pdm location 0.0.0.0 0.0.0.0 outside
pdm history enable
arp timeout 14400
global (outside) 10 interface
nat (inside) 10 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 111.222.33.444 555.66.77.888 netmask 255.255.255.255 0 0

static (inside,outside) 111.222.33.444 555.66.77.888 netmask 255.255.255.255 0 0

access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 111.222.33.4 1
route inside 555.66.77.888 255.255.255.255 111.222.33.444 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 555.66.0.0 255.255.0.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:015e0ef25285fbe5e1a90e0006b8e5d9
: end

\
0
Comment
Question by:enorman1
  • 8
  • 6
14 Comments
 
LVL 10

Expert Comment

by:qbakies
ID: 33424586
Basic addition to your current setup:

static (inside,outside) <PUBLIC IP> <IP OF THE WEBSITE> netmask 255.255.255.255 0 0
access-list outside_access_in permit tcp any any eq 443
access-list outside_access_in permit tcp any any eq 102
0
 
LVL 10

Expert Comment

by:qbakies
ID: 33424647
Sorry, too quick with the copy/paste...

static (inside,outside) <PUBLIC IP> <IP OF THE WEBSITE> netmask 255.255.255.255 0 0
access-list outside_access_in permit udp any host <PUBLIC IP> eq 443
access-list outside_access_in permit udp any host <PUBLIC IP> eq 120
0
 
LVL 10

Expert Comment

by:qbakies
ID: 33424666
I really wish there was an edit option...once again

static (inside,outside) <PUBLIC IP> <IP OF THE WEBSITE> netmask 255.255.255.255 0 0
access-list outside_access_in permit tcp any host <PUBLIC IP> eq 443
access-list outside_access_in permit tcp any host <PUBLIC IP> eq 120
0
 

Author Comment

by:enorman1
ID: 33424796
One quick note, the only way to access this web site is through a VPN. does your config above still apply ?
0
 
LVL 10

Expert Comment

by:qbakies
ID: 33429317
No it doesn't, that config would be for allowing outside traffic to your website.  I don't see any VPN config on your PIX.  Do they VPN to your network through a different device?
0
 

Author Comment

by:enorman1
ID: 33429398
We're using vpn software from hte client. I do have the ports open:443 and 102. Isntead of using an ip for the wed site, can i alternatively use the wed site address (url) ?
0
 
LVL 10

Expert Comment

by:qbakies
ID: 33429433
I need to understand your VPN better to answer this.  From what I'm getting so far your clients are running a VPN client that allows them to connect to your network and it required you to open ports 443 and 102.  Is that correct?

What VPN solution are you using?

What are you using for authentication?

0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 

Author Comment

by:enorman1
ID: 33429521
That's fairly correct. Let me expalin. 2 clients from inside the network are trying to access a secured web site via Cisco vpn. I'm using a pix 501configured to allow ipsec pass-through. my clients have static ip's assigned to their workstations. on the pix, i have a static mapping from the client to a public ip. Once the client has successfully conencted via vpn, they then try to access 1 specific https web site. Does this help ?
0
 
LVL 10

Expert Comment

by:qbakies
ID: 33429602
Actually I'm more confused now...so you have two users with workstations inside your LAN that are connecting via VPN to another location to access a secure website?  
0
 

Author Comment

by:enorman1
ID: 33429743
Yup. that's exactly right.
0
 
LVL 10

Accepted Solution

by:
qbakies earned 125 total points
ID: 33429827
Then there is nothing that you should need to do.  Once they are connected to the remote VPN any 'interesting traffic' (as defined by the Cisco device they to which they are connecting) will be passed down the tunnel.  Your firewall has nothing to do with it anymore.  The configuration of the Cisco device to which they are connecting needs to be setup to see them trying to hit the secure website as interesting traffic and send that down the tunnel.

Remember that firewalls are only meant to keep things from getting into your network that shouldn't, not keep things from getting out (unless you have them configured that way for some reason).  I'm actually surprised you had to configure IPsec pass-through but it must be because you are using a 501 with an older PIX Version.  Once your clients make that VPN connection your firewall is out of the loop.  The Cisco device on the other end is what need to be adjusted.
0
 

Author Closing Comment

by:enorman1
ID: 33432661
Thanks
0
 

Author Comment

by:enorman1
ID: 33432665
Your answer were right on the money. Thank you.
0
 
LVL 10

Expert Comment

by:qbakies
ID: 33432683
Glad I could help clear things up.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
Exchange server is not supported in any cloud-hosted platform (other than Azure with Azure Premium Storage).
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now