Solved

OWA redirect

Posted on 2010-08-12
44
568 Views
Last Modified: 2012-05-10
Hi All

I am trying to setup a redirect for my OWA access. WE are currently using Server 2003 with exchange 2003. I have followed the steps in the following KB http://support.microsoft.com/kb/839357 
For the most part it is working. when I browse to http://mycompany/exchange it works but I want it so I can go to http://mycompany and it will redirect me to https://mycompany.
I followed the directions at the bottom of the KB mentioned above and it still does not work.

I am aware there are other methods but I would like to stike to this one
0
Comment
Question by:OTNAdmin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 21
  • 20
  • 2
  • +1
44 Comments
 
LVL 3

Expert Comment

by:P0rter
ID: 33425130
Use this as index.aspx

<%
Response.Redirect("https://" & Request.ServerVariables("HTTP_HOST") & "/exchange")
%>

dont forget to set it as default document
0
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 33425439
Hi,

Refer this:
http://www.amset.info/exchange/owa-defaultpage.asp

Hope this helps,
Shree
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33426172
you need to create the custom errors folder and include an asp file with the following
then modify the error for 403 and use the /CustomErrors/yourasp.asp
<%

If Request.ServerVariables("HTTPS")  = "off" Then
	Response.Redirect "https://" & Request.ServerVariables("HTTP_HOST") & "/Exchange"
End If

%>

Open in new window

0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:OTNAdmin
ID: 33432370
I have followed both instructions above with no success. I have attached a pic to how my IIS looks. by all accounts this should be working.

The error when I browse to the page is "The Website Declined to SHow This Page" The website requires you to login
exchange.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33432432
your custom errors tab should look like the following

custom-error.PNG
0
 

Author Comment

by:OTNAdmin
ID: 33432939
my custom errors is setupthe exact same ways as yours
0
 
LVL 34

Expert Comment

by:Shreedhar Ette
ID: 33434084
Hi OTNAdmin,

Request you to once again cross vefiy your settings as per the http://support.microsoft.com/kb/839357 

---------
Shree
0
 

Author Comment

by:OTNAdmin
ID: 33441049
I have double and triple checked the settings and everthing is fine. I have just about given up on this. are there any logs I can post?

How would I go about setting up another redirection?
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33444781
you can look at your iis logs
look for connections to /exchange on port 80
at the end of the line you should see an http error code

post a few lines from the logs
c:\windows\system32\logfiles\w3svc1
0
 

Author Comment

by:OTNAdmin
ID: 33454689
Here is the entry of me trying to access the website

2010-08-17 13:58:25 W3SVC1 10.224.131.104 GET / - 80 - 10.224.102.137 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E;+MS-RTC+LM+8) 403 4 5
2010-08-17 13:58:26 W3SVC1 10.224.131.104 GET / - 80 - 10.224.102.137 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E;+MS-RTC+LM+8) 403 4 5
2010-08-17 13:58:27 W3SVC1 10.224.131.104 GET / - 80 - 10.224.102.137 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E;+MS-RTC+LM+8) 403 4 5
2010-08-17 13:58:29 W3SVC1 10.224.131.104 GET / - 80 - 10.224.102.137 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E;+MS-RTC+LM+8) 403 4 5
2010-08-17 13:58:29 W3SVC1 10.224.131.104 GET / - 80 - 10.224.102.137 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E;+MS-RTC+LM+8) 403 4 5
2010-08-17 13:58:30 W3SVC1 10.224.131.104 GET / - 80 - 10.224.102.137 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E;+MS-RTC+LM+8) 403 4 5
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33454744
the custom error page is not being detected

Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
Expand Computer Name, and then expand Web Sites.
Expand the Web site that your OWA users use to access their Exchange server. By default, this Web site will be the Default Web Site.
Right-click the CustomErrors folder, and then click Properties.
Under the Application settings section, click Create.
Make sure that CustomErrors is displayed in the Application name box.
For Exchange 2003 running on IIS 6.0, click ExchangeApplicationPool in the Application Pool list.
Click the Documents tab, and then add the Owahttps.asp file to the Enable default content page. Move the Owahttps.asp file to the top of the list.
Click the Directory Security tab, and then click Edit under Authentication and access control.
Click to select Enable anonymous access, and then click OK.
Under Secure communications, click Edit.
Click to clear the Require secure channel (SSL) check box, and then click OK two times.
0
 

Author Comment

by:OTNAdmin
ID: 33455115
all the above steps are true.

I have attached a pic of my IIS screen when I right click on the owahttps.asp it comes up with a cert warning and when I ignore it i get to my webmail page
IIS.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33455320
the connection attempts from your log are for the main site not the exchange vdir

did you also setup the custom error for the main page
0
 

Author Comment

by:OTNAdmin
ID: 33455421
This is what the custom error looks like under my default website
customerror.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33455448
the line in your log shows that someone attempted to browse to http://server and that this site is set to require https

2010-08-17 13:58:25 W3SVC1 10.224.131.104 GET / - 80 - 10.224.102.137 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729;+.NET4.0C;+.NET4.0E;+MS-RTC+LM+8) 403 4 5


can you try http://server/exchange

0
 

Author Comment

by:OTNAdmin
ID: 33455684
That works just fine, I can browse to that and it redirects me to the https link
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33455729
you need to modify the custom errors tab on the default web site, same as you did for exchange vdir, or remove teh require ssl
0
 

Author Comment

by:OTNAdmin
ID: 33455818
I have done that, with no luck. I do not want to remove the SSL option because if I do then i am losing my encryption.
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33455908
you need to create a second asp file that does not include the /exchange at the end
add it to the documents
then modify the custom error for 403.4 using the second asp file name
0
 

Author Comment

by:OTNAdmin
ID: 33456963
under which section should place the new asp file? the default web site? the Exchange virtual directory or Custom errors direcoty?
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33457063
put the actual file in the same directory (ex. mainredirect.asp)
add mainredirect.asp to the list under the documents tab for the main site and move it to the top
modify the custom error for the default web site using the mainredirect.asp
0
 

Author Comment

by:OTNAdmin
ID: 33457164
ok an how should the asp file look should it look like should like

 <%

If Request.ServerVariables("HTTPS")  = "off" Then
                                    Response.Redirect "https://" & Request.ServerVariables("HTTP_HOST")
End If

      %>
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33457246
yes, that should work
0
 

Author Comment

by:OTNAdmin
ID: 33457406
still no luck

I made the script mentioned above and place in in the Documents area and changed the cutom errors section of the default website
deafult.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33457436
what happens when they go to http://server
0
 

Author Comment

by:OTNAdmin
ID: 33457653
the error below, is there another way
error.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33457826
is anonymous access enabled for the default web site
0
 

Author Comment

by:OTNAdmin
ID: 33457949
yes it is
0
 

Author Comment

by:OTNAdmin
ID: 33457991
Here a Pic of my main IIS, is this what it is suppose to look like
main.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33458120
can you provide an image of the home directory tab for the default web site
0
 

Author Comment

by:OTNAdmin
ID: 33458141
The home directory
home.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33458194
remove the redirection to a url
it is redirecting to the exchange with http and since it is a redirect the custom error doesn't work

if you want http://server to redirect to https://server/exchange then switch this setting back to "A directory located on this computer" and use the custom error used for the exchnage vdir
0
 

Author Comment

by:OTNAdmin
ID: 33458363
something like this
error02.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33458393
i would set it back to the original
c:\inetpub\wwwroot
0
 

Author Comment

by:OTNAdmin
ID: 33458463
So i am not to sure what you mean by you other comment can you please clarifiy
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33458563
change that directory to c:\inetpub\wwwroot
at that point when you go to http:\\server you should be redirected to https:\\server

if you want this to send you to https:\\server\exchange (which i'm guessing you want based on the original redirect), you should change the custom error setting for 403.4 to the asp page used on the Exchange virtual directory custom error
0
 

Author Comment

by:OTNAdmin
ID: 33458730
I have made that change still with no luck, the custom errors tab on both the default web site and exchange virtual direcoty are the same.

I dont have anything loaded in the documents tab should ?
documents.jpg
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33458750
you need to add the .asp file and move it to the top
0
 

Author Comment

by:OTNAdmin
ID: 33458779
to which one?
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33458860
Both
0
 

Author Comment

by:OTNAdmin
ID: 33458927
no luck, i tried that. I can browse to http://mycompany/exchange with no issues
0
 
LVL 32

Accepted Solution

by:
endital1097 earned 500 total points
ID: 33460494
i check a working configuration and here is what i had done previously
on the default web site:
Home directory tab - a redirection to a URL = /exchange
                              - Application pool = ExchangeApplicationPool
Directory security tab - Anonymous enabled
                                  - Require SSL unchecked
Custom errors tab - 403;3  = /CustomErrors/owaredirect.asp

although you are not requiring SSL on the main page the redirect sends you to exhcange vdir which will go to SSL
0
 

Author Comment

by:OTNAdmin
ID: 33464505
It is FINALLLY working thanks for all the help. I didnt have fo uncheck the requrie SSL on the default web site. Ifyou recall from you of my earlier posts the Home Directory under the default website is the section Appliction pool is DefaultAppPool. I took your advace and changed it to ExchangeApplicationPool and it started to work
0
 
LVL 32

Expert Comment

by:endital1097
ID: 33464544
woo hoo
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
This article will help to fix the below errors for MS Exchange Server 2013 I. Certificate error "name on the security certificate is invalid or does not match the name of the site" II. Out of Office not working III. Make Internal URLs and Externa…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

624 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question