• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 945
  • Last Modified:

RDC Port Forwarding from public WAN IP (WAN Modem: SMB 8014) to LAN IP (Router: Cisco Valet Plus) to W2k3 Server.

Trying to forward RDC (port 3389) through Comcast Business Gateway (SMB8014) to Cisco Valet Plus, and again from Cisco Valet Plus to my server. I have added a "forward a single port" on the Valet by entering the following settings into Applications & Gaming:

External Port: 3389, Internal Port: 3389, Protocol: TCP, To IP Address: 192.168.4.X (local server IP assigned by Cisco router)

I have my SMB set to the following in Port Forwarding:

App Name: Remote, Public: 3389, Private: 3389 ~ 3389, Protocol: TCP, IP Address: 10.1.10.X (local Cisco IP assigned by SMB router)

Comcast has already set up the Gateway to forward our static IP to the router (or so they say). The only difference I see is that they checked off "Disable Firewall for True Static IP Subnet Only" but this SMB router is completely foreign to me. Basically, I'm trying to remote into my static IP and have it go right to the server through the Valet. So far, no dice.

I can however connect to the server via RDC locally without a problem (using 192.168.4.x IP address of the server) but not with our public static IP which is the ultimate goal.

Any help would be greatly appreciated!

Any help would be greatly appreciated!
0
hybridmoments82
Asked:
hybridmoments82
  • 4
  • 3
1 Solution
 
TechnicallyMaybeCommented:
Can you verify that the Valet's WAN address is the public IP assigned to you?  If it is not, then the Business Gateway is still in routed mode, not bridged.
0
 
hybridmoments82Author Commented:
No. The address of the Valet is an assigned address by the SMB (10.1.10.X).
0
 
hybridmoments82Author Commented:
How do I set the SMB to bridged mode?
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
TechnicallyMaybeCommented:
Most likely the Comcast device is controlled by Comcast and they won't give you access.
When they put it in bridged mode, all it does it pass traffic as though it is invisible.  The public IP will be assigned to the WAN port of the Cisco Valet.  Then the port mapping will work.
0
 
hybridmoments82Author Commented:
Apparently, the SMB wasn't in "bridged" mode. Had to look up how to set it in bridged mode. All is working perfectly now. Thanks!
0
 
hybridmoments82Author Commented:
Nice!
0
 
TechnicallyMaybeCommented:
Glad to help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now